summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2013-12-27 01:05:14 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-06 11:13:59 +0000
commit0cfb1e7a9f8349def5da787d3a284ac6d18ca55d (patch)
tree9e05a7eda2b5c1ebb553bf10a6d803dd32c5a0e2 /meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
parent484727e25f312a4df02047515c4ff729e3287aff (diff)
downloadpoky-0cfb1e7a9f8349def5da787d3a284ac6d18ca55d.tar.gz
autogen-native: upgrade to 5.18.2
* Upgrade from 5.17.4 to 5.18.2 * Rename files -> autogen (From OE-Core rev: 6bcd2dafa379badab11bff9d7b607f7f5d72fc94) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.18.2.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
new file mode 100644
index 0000000000..c7950c3c6a
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
@@ -0,0 +1,31 @@
1SUMMARY = "AutoGen is a tool to manage programs that contain large amounts of repetitious text."
2DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
3 maintenance of programs that contain large amounts of repetitious text.\
4 It is especially valuable in programs that have several blocks of text\
5 that must be kept synchronized."
6HOMEPAGE = "http://www.gnu.org/software/autogen/"
7SECTION = "devel"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
12 file://guile.patch \
13 file://increase-timeout-limit.patch"
14
15SRC_URI[md5sum] = "117c4bc5613c57e1b97d760a5d1910a4"
16SRC_URI[sha256sum] = "cc2702dec21ba5b01144865163f6d1a54268d2b72aafc5520ad0e0cb57104068"
17
18DEPENDS = "guile-native libtool-native libxml2-native"
19
20inherit autotools native
21
22# autogen-native links against libguile which may have been relocated with sstate
23# these environment variables ensure there isn't a relocation issue
24export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
25export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
26
27do_install_append () {
28 create_wrapper ${D}/${bindir}/autogen \
29 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
30 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
31}