summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.18.2.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
new file mode 100644
index 0000000000..98bdb59792
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Automated text and program generation tool"
2DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
3 maintenance of programs that contain large amounts of repetitious text.\
4 It is especially valuable in programs that have several blocks of text\
5 that must be kept synchronized."
6HOMEPAGE = "http://www.gnu.org/software/autogen/"
7SECTION = "devel"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
12 file://guile.patch \
13 file://increase-timeout-limit.patch"
14
15SRC_URI[md5sum] = "117c4bc5613c57e1b97d760a5d1910a4"
16SRC_URI[sha256sum] = "cc2702dec21ba5b01144865163f6d1a54268d2b72aafc5520ad0e0cb57104068"
17
18DEPENDS = "guile-native libtool-native libxml2-native"
19
20inherit autotools native
21
22# autogen-native links against libguile which may have been relocated with sstate
23# these environment variables ensure there isn't a relocation issue
24export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
25export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
26
27do_install_append () {
28 create_wrapper ${D}/${bindir}/autogen \
29 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
30 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
31}