summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.18.10.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-06-12 01:25:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 08:35:00 +0100
commit4690723161ef1a9632a9892bd0ec848ab527dd07 (patch)
treebe666fb2dd00b385d42f63fafbdd4d1fa72b7e9c /meta/recipes-devtools/autogen/autogen-native_5.18.10.bb
parent4b777079066e6fa72d7c9db1e1cae3ebb9338351 (diff)
downloadpoky-4690723161ef1a9632a9892bd0ec848ab527dd07.tar.gz
autogen-native: 5.18.6 -> 5.18.10
Removed redirect-output-dir.patch, there is no /tmp/mklibsrc-log.tx, so the patch is not needed any more. (From OE-Core rev: bb5c0e91063f705c5e1ce319b4742e06f6aa4c97) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.18.10.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.10.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.10.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.10.bb
new file mode 100644
index 0000000000..fd52c83bd0
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.10.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Automated text and program generation tool"
2DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
3 maintenance of programs that contain large amounts of repetitious text.\
4 It is especially valuable in programs that have several blocks of text\
5 that must be kept synchronized."
6HOMEPAGE = "http://www.gnu.org/software/autogen/"
7SECTION = "devel"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
12 file://increase-timeout-limit.patch \
13 file://mk-tpl-config.sh-force-exit-value-to-be-0-in-subproc.patch \
14"
15
16SRC_URI[md5sum] = "2d1b5226e1929d0680011df631289571"
17SRC_URI[sha256sum] = "0b8681d9724c481d3b726b5a9e81d3d09dc7f307d1a801c76d0a30d8f843d20a"
18
19UPSTREAM_CHECK_URI = "http://ftp.gnu.org/gnu/autogen/"
20UPSTREAM_CHECK_REGEX = "rel(?P<pver>\d+(\.\d+)+)/"
21
22DEPENDS = "guile-native libtool-native libxml2-native"
23
24inherit autotools texinfo native pkgconfig
25
26# autogen-native links against libguile which may have been relocated with sstate
27# these environment variables ensure there isn't a relocation issue
28export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
29export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
30
31do_install_append () {
32 create_wrapper ${D}/${bindir}/autogen \
33 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
34 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
35}