summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autoconf/autoconf_2.69.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2021-02-04 15:52:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-07 22:26:42 +0000
commitc9299cea8306a7fb7c13abd8a287dd3b7af36ab7 (patch)
tree9667bc5f3f52e86aa70799a1e888ff14eee92524 /meta/recipes-devtools/autoconf/autoconf_2.69.bb
parent915a6afc3cfdf48eff8dcc5bb32eebcbb999eca1 (diff)
downloadpoky-c9299cea8306a7fb7c13abd8a287dd3b7af36ab7.tar.gz
autoconf: merge .bb and .inc files
These files are split for historical reasons, so merge them to make maintaining them easier. The bb and inc had differing LICENSE assignments. Current autoconf is GPLv3+. (From OE-Core rev: 192f635fa6964213e771c0b1443b2c15863b3d57) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/autoconf/autoconf_2.69.bb')
-rw-r--r--meta/recipes-devtools/autoconf/autoconf_2.69.bb57
1 files changed, 55 insertions, 2 deletions
diff --git a/meta/recipes-devtools/autoconf/autoconf_2.69.bb b/meta/recipes-devtools/autoconf/autoconf_2.69.bb
index 2e1b9bdc90..e30536a221 100644
--- a/meta/recipes-devtools/autoconf/autoconf_2.69.bb
+++ b/meta/recipes-devtools/autoconf/autoconf_2.69.bb
@@ -1,8 +1,14 @@
1require autoconf.inc 1SUMMARY = "A GNU tool that produce shell scripts to automatically configure software"
2DESCRIPTION = "Autoconf is an extensible package of M4 macros that produce shell scripts to automatically \
3configure software source code packages. Autoconf creates a configuration script for a package from a template \
4file that lists the operating system features that the package can use, in the form of M4 macro calls."
5LICENSE = "GPLv3+"
6HOMEPAGE = "http://www.gnu.org/software/autoconf/"
7SECTION = "devel"
8DEPENDS = "m4-native gnu-config-native"
2 9
3PR = "r11" 10PR = "r11"
4 11
5LICENSE = "GPLv2 & GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ 12LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504" 13 file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504"
8 14
@@ -26,6 +32,53 @@ SRC_URI[sha256sum] = "954bd69b391edc12d6a4a51a2dd1476543da5c6bbf05a95b59dc0dd6fd
26 32
27SRC_URI_append_class-native = " file://fix_path_xtra.patch" 33SRC_URI_append_class-native = " file://fix_path_xtra.patch"
28 34
35RDEPENDS_${PN} = "m4 gnu-config \
36 perl \
37 perl-module-bytes \
38 perl-module-carp \
39 perl-module-constant \
40 perl-module-data-dumper \
41 perl-module-errno \
42 perl-module-exporter \
43 perl-module-file-basename \
44 perl-module-file-compare \
45 perl-module-file-copy \
46 perl-module-file-find \
47 perl-module-file-glob \
48 perl-module-file-path \
49 perl-module-file-spec \
50 perl-module-file-spec-unix \
51 perl-module-file-stat \
52 perl-module-getopt-long \
53 perl-module-io-file \
54 perl-module-overloading \
55 perl-module-posix \
56 perl-module-symbol \
57 perl-module-thread-queue \
58 perl-module-threads \
59 "
60RDEPENDS_${PN}_class-native = "m4-native gnu-config-native hostperl-runtime-native"
61
62inherit autotools texinfo
63
64PERL = "${USRBINPATH}/perl"
65PERL_class-native = "/usr/bin/env perl"
66PERL_class-nativesdk = "/usr/bin/env perl"
67
68CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
69
29EXTRA_OECONF += "ac_cv_path_M4=m4 ac_cv_prog_TEST_EMACS=no" 70EXTRA_OECONF += "ac_cv_path_M4=m4 ac_cv_prog_TEST_EMACS=no"
30 71
72do_configure() {
73 # manually install a newer config.guess/.sub
74 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/build-aux
75 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/build-aux
76
77 oe_runconf
78}
79
80do_install_append() {
81 rm -rf ${D}${datadir}/emacs
82}
83
31BBCLASSEXTEND = "native nativesdk" 84BBCLASSEXTEND = "native nativesdk"