summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autoconf/autoconf_2.69.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2020-07-15 16:03:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-07 22:26:42 +0000
commitbdad4025c7d3e21fc99eb1055746aeb69fd8d915 (patch)
treecb34eb832858cff00d3c7281c38251a668c9bf63 /meta/recipes-devtools/autoconf/autoconf_2.69.bb
parent1dbef3ce981495ad08ca045c6ad80a7417f4619c (diff)
downloadpoky-bdad4025c7d3e21fc99eb1055746aeb69fd8d915.tar.gz
autoconf: upgrade to 2.71
After too many years, autoconf has made a new release. On the whole it is compatible with previous releases, but some macros are more specific about what they expose so minor tweaks to configure.ac may be required. autoconf also now invokes intltoolize, gtkdocize, and copies config.sub/guess, so there is less work for autotools.bbclass to do. - AC_HEADER_MAJOR-port-to-glibc-2.25.patch - add_musl_config.patch - autoconf-replace-w-option-in-shebangs-with-modern-use-warnings.patch - autoreconf-gnuconfigize.patch - check-automake-cross-warning.patch - config_site.patch - fix_path_xtra.patch - performance.patch Drop a number of patches which have been integrated upstream. - man-host-perl.patch Don't use the target perl path when building documentation at build time: - no-man.patch Don't build documentation in native builds to avoid further build dependencies. (From OE-Core rev: f5dd2e0acbb0aa4079c51aaeab8c26e743a4c714) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/autoconf/autoconf_2.69.bb')
-rw-r--r--meta/recipes-devtools/autoconf/autoconf_2.69.bb84
1 files changed, 0 insertions, 84 deletions
diff --git a/meta/recipes-devtools/autoconf/autoconf_2.69.bb b/meta/recipes-devtools/autoconf/autoconf_2.69.bb
deleted file mode 100644
index e30536a221..0000000000
--- a/meta/recipes-devtools/autoconf/autoconf_2.69.bb
+++ /dev/null
@@ -1,84 +0,0 @@
1SUMMARY = "A GNU tool that produce shell scripts to automatically configure software"
2DESCRIPTION = "Autoconf is an extensible package of M4 macros that produce shell scripts to automatically \
3configure software source code packages. Autoconf creates a configuration script for a package from a template \
4file that lists the operating system features that the package can use, in the form of M4 macro calls."
5LICENSE = "GPLv3+"
6HOMEPAGE = "http://www.gnu.org/software/autoconf/"
7SECTION = "devel"
8DEPENDS = "m4-native gnu-config-native"
9
10PR = "r11"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
13 file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504"
14
15SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.gz \
16 file://program_prefix.patch \
17 file://check-automake-cross-warning.patch \
18 file://autoreconf-exclude.patch \
19 file://autoreconf-gnuconfigize.patch \
20 file://config_site.patch \
21 file://remove-usr-local-lib-from-m4.patch \
22 file://preferbash.patch \
23 file://autotest-automake-result-format.patch \
24 file://add_musl_config.patch \
25 file://performance.patch \
26 file://AC_HEADER_MAJOR-port-to-glibc-2.25.patch \
27 file://autoconf-replace-w-option-in-shebangs-with-modern-use-warnings.patch \
28 "
29
30SRC_URI[md5sum] = "82d05e03b93e45f5a39b828dc9c6c29b"
31SRC_URI[sha256sum] = "954bd69b391edc12d6a4a51a2dd1476543da5c6bbf05a95b59dc0dd6fd4c2969"
32
33SRC_URI_append_class-native = " file://fix_path_xtra.patch"
34
35RDEPENDS_${PN} = "m4 gnu-config \
36 perl \
37 perl-module-bytes \
38 perl-module-carp \
39 perl-module-constant \
40 perl-module-data-dumper \
41 perl-module-errno \
42 perl-module-exporter \
43 perl-module-file-basename \
44 perl-module-file-compare \
45 perl-module-file-copy \
46 perl-module-file-find \
47 perl-module-file-glob \
48 perl-module-file-path \
49 perl-module-file-spec \
50 perl-module-file-spec-unix \
51 perl-module-file-stat \
52 perl-module-getopt-long \
53 perl-module-io-file \
54 perl-module-overloading \
55 perl-module-posix \
56 perl-module-symbol \
57 perl-module-thread-queue \
58 perl-module-threads \
59 "
60RDEPENDS_${PN}_class-native = "m4-native gnu-config-native hostperl-runtime-native"
61
62inherit autotools texinfo
63
64PERL = "${USRBINPATH}/perl"
65PERL_class-native = "/usr/bin/env perl"
66PERL_class-nativesdk = "/usr/bin/env perl"
67
68CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
69
70EXTRA_OECONF += "ac_cv_path_M4=m4 ac_cv_prog_TEST_EMACS=no"
71
72do_configure() {
73 # manually install a newer config.guess/.sub
74 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/build-aux
75 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/build-aux
76
77 oe_runconf
78}
79
80do_install_append() {
81 rm -rf ${D}${datadir}/emacs
82}
83
84BBCLASSEXTEND = "native nativesdk"