summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt/apt_1.2.12.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2016-07-29 14:53:01 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-04 15:22:21 +0100
commit8b21a516b0824aa6b47fa21287b160edfa232d96 (patch)
tree7ecb48d5cc0ca1a0195ab3fb47bde306658680ee /meta/recipes-devtools/apt/apt_1.2.12.bb
parent564657edae7adfbd777cac9d313a6ccf8f37579c (diff)
downloadpoky-8b21a516b0824aa6b47fa21287b160edfa232d96.tar.gz
apt: Upgrade to 1.2.12
Test was made building core-image-sato with package_deb on qemux86 and qemuarm then run for two of them testimage and install packages with apt-get using PACKAGE_FEED_URI's configuration. Now apt support drop priviligies for install packages using a sandbox with _apt user, the useradd class was inherit and configured to install _apt user and group. Rebased patches: - 0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch - 0001-fix-the-gcc-version-check.patch - 0001-remove-Wsuggest-attribute-from-CFLAGS.patch - disable-test.patch - no-curl.patch (From OE-Core rev: 369a7f7232aa8406b63376f7888896fe90f9ce40) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/apt/apt_1.2.12.bb')
-rw-r--r--meta/recipes-devtools/apt/apt_1.2.12.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/apt/apt_1.2.12.bb b/meta/recipes-devtools/apt/apt_1.2.12.bb
new file mode 100644
index 0000000000..85c0d56159
--- /dev/null
+++ b/meta/recipes-devtools/apt/apt_1.2.12.bb
@@ -0,0 +1,19 @@
1DEPENDS = "curl db zlib"
2RDEPENDS_${PN} = "dpkg bash debianutils"
3require apt.inc
4
5require apt-package.inc
6
7PACKAGECONFIG ??= "lzma"
8PACKAGECONFIG[lzma] = "ac_cv_lib_lzma_lzma_easy_encoder=yes,ac_cv_lib_lzma_lzma_easy_encoder=no,xz"
9PACKAGECONFIG[bz2] = "ac_cv_lib_bz2_BZ2_bzopen=yes,ac_cv_lib_bz2_BZ2_bzopen=no,bzip2"
10
11FILES_${PN} += "${bindir}/apt-key"
12apt-manpages += "doc/apt-key.8"
13
14do_install_append() {
15 #Write the correct apt-architecture to apt.conf
16 APT_CONF=${D}/etc/apt/apt.conf
17 echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
18 oe_libinstall -so -C bin libapt-private ${D}${libdir}/
19}