summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-self-hosted.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-29 11:38:34 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 12:52:55 +0100
commit272cb74d70686cb7f72005dc25e02f38b46ecd57 (patch)
tree3a5e4cb0c9a2e407b2d04c78b1eb51d0f429ca64 /meta/recipes-core/tasks/task-self-hosted.bb
parentf1df3f828bfc9e70bf8cf5a7c2e2cf216944785a (diff)
downloadpoky-272cb74d70686cb7f72005dc25e02f38b46ecd57.tar.gz
Rename task to packagegroup
"Package group" is a much more appropriate name for these than task, since we use the word task to describe units of work executed by BitBake. (From OE-Core rev: 424dcf7046e4ad09dcc664eb1992201195247fcf) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/tasks/task-self-hosted.bb')
-rw-r--r--meta/recipes-core/tasks/task-self-hosted.bb202
1 files changed, 0 insertions, 202 deletions
diff --git a/meta/recipes-core/tasks/task-self-hosted.bb b/meta/recipes-core/tasks/task-self-hosted.bb
deleted file mode 100644
index 4d6ab07964..0000000000
--- a/meta/recipes-core/tasks/task-self-hosted.bb
+++ /dev/null
@@ -1,202 +0,0 @@
1#
2# Copyright (C) 2010 Intel Corporation
3#
4
5DESCRIPTION = "Create Basic Image Tasks"
6PR = "r11"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
9 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
10
11PACKAGES = "\
12 task-self-hosted \
13 task-self-hosted-debug \
14 task-self-hosted-sdk \
15 task-self-hosted-extended \
16 task-self-hosted-graphics \
17 task-self-hosted-host-tools \
18 "
19
20ALLOW_EMPTY = "1"
21
22RDEPENDS_task-self-hosted = "\
23 task-self-hosted-debug \
24 task-self-hosted-sdk \
25 task-self-hosted-extended \
26 task-self-hosted-graphics \
27 task-self-hosted-host-tools \
28 "
29
30RDEPENDS_task-self-hosted-host-tools = "\
31 connman \
32 connman-plugin-ethernet \
33 dhcp-client \
34 e2fsprogs \
35 e2fsprogs-e2fsck \
36 e2fsprogs-mke2fs \
37 e2fsprogs-tune2fs \
38 genext2fs \
39 hdparm \
40 iptables \
41 kernel-module-tun \
42 kernel-module-iptable-raw \
43 kernel-module-iptable-nat \
44 kernel-module-iptable-mangle \
45 kernel-module-iptable-filter \
46 lsb \
47 mc \
48 parted \
49 pseudo \
50 screen \
51 vte \
52 "
53
54# eglibc-utils: for rpcgen
55RDEPENDS_task-self-hosted-sdk = "\
56 autoconf \
57 automake \
58 binutils \
59 binutils-symlinks \
60 ccache \
61 coreutils \
62 cpp \
63 cpp-symlinks \
64 distcc \
65 eglibc-utils \
66 eglibc-gconv-ibm850 \
67 file \
68 findutils \
69 g++ \
70 g++-symlinks \
71 gcc \
72 gcc-symlinks \
73 intltool \
74 ldd \
75 less \
76 libstdc++ \
77 libstdc++-dev \
78 libtool \
79 make \
80 mktemp \
81 perl-module-re \
82 perl-module-text-wrap \
83 pkgconfig \
84 quilt \
85 sed \
86 "
87
88RDEPENDS_task-self-hosted-debug = " \
89 gdb \
90 gdbserver \
91 rsync \
92 strace \
93 tcf-agent"
94
95
96RDEPENDS_task-self-hosted-extended = "\
97 bzip2 \
98 chkconfig \
99 chrpath \
100 cpio \
101 curl \
102 diffstat \
103 diffutils \
104 elfutils \
105 expat \
106 gamin \
107 gawk \
108 gdbm \
109 gettext \
110 gettext-runtime \
111 git \
112 grep \
113 groff \
114 gzip \
115 hicolor-icon-theme \
116 libaio \
117 libusb1 \
118 libxml2 \
119 lrzsz \
120 lsof \
121 lzo \
122 man \
123 man-pages \
124 mdadm \
125 minicom \
126 mtools \
127 ncurses \
128 neon \
129 nfs-utils \
130 nfs-utils-client \
131 openssl \
132 opkg \
133 opkg-utils \
134 patch \
135 perl \
136 perl-dev \
137 perl-modules \
138 perl-pod \
139 ${PTH} \
140 python \
141 python-compile \
142 python-compiler \
143 python-compression \
144 python-core \
145 python-curses \
146 python-datetime \
147 python-distutils \
148 python-elementtree \
149 python-email \
150 python-fcntl \
151 python-logging \
152 python-misc \
153 python-multiprocessing \
154 python-netclient \
155 python-netserver \
156 python-pickle \
157 python-pkgutil \
158 python-re \
159 python-rpm \
160 python-shell \
161 python-sqlite3 \
162 python-subprocess \
163 python-textutils \
164 python-unixadmin \
165 python-xmlrpc \
166 quota \
167 readline \
168 rpm \
169 setserial \
170 socat \
171 subversion \
172 sudo \
173 sysstat \
174 tar \
175 tcl \
176 texi2html \
177 texinfo \
178 unzip \
179 usbutils \
180 watchdog \
181 wget \
182 which \
183 xinetd \
184 zip \
185 zlib \
186 "
187
188
189RDEPENDS_task-self-hosted-graphics = "\
190 builder \
191 libgl \
192 libgl-dev \
193 libglu \
194 libglu-dev \
195 libsdl \
196 libsdl-dev \
197 libx11-dev \
198 python-pygtk \
199 gtk-theme-clearlooks \
200 "
201PTH = "pth"
202PTH_libc-uclibc = ""