summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_199.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-04-17 00:01:44 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-16 23:05:59 +0100
commita7aec392577b72b593dc55139d80c3cf98cc6484 (patch)
tree657926f57b3c36ebacc3200a4e3292f90293a0a4 /meta/recipes-core/systemd/systemd_199.bb
parentc1914d7a061212652c2024534a7cdfe1ab143f4e (diff)
downloadpoky-a7aec392577b72b593dc55139d80c3cf98cc6484.tar.gz
systemd: use AC_CHECK_TOOL instead of AC_PATH_TOOL when checking objcopy, strings, gperf
* with external toolchain I have different HOST_PREFIX and HOST_SYS AC_PATH_TOOL is using HOST_SYS as prefix and fails to find objcopy then it tries objcopy without prefix which is found on host, but that objcopy does not work for arm libs * with internal toolchain gperf is not prefixed with HOST_PREFIX, but fallback to "gperf" only finds the one in native sysroot first * based on http://lists.linuxtogo.org/pipermail/openembedded-core/2013-April/037985.html (From OE-Core rev: 6ae99136f1c1c59f4e55331c43cf0c0bac5abcdd) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd_199.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_199.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_199.bb b/meta/recipes-core/systemd/systemd_199.bb
index d22df12c6d..bbe19eae10 100644
--- a/meta/recipes-core/systemd/systemd_199.bb
+++ b/meta/recipes-core/systemd/systemd_199.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe \
9PROVIDES = "udev" 9PROVIDES = "udev"
10 10
11PE = "1" 11PE = "1"
12PR = "r2" 12PR = "r3"
13 13
14DEPENDS = "kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline dbus libcap libcgroup tcp-wrappers glib-2.0" 14DEPENDS = "kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline dbus libcap libcgroup tcp-wrappers glib-2.0"
15DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" 15DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
@@ -27,6 +27,7 @@ SRC_URI = "http://www.freedesktop.org/software/systemd/systemd-${PV}.tar.xz \
27 file://0002-readahead-chunk-on-spinning-media.patch \ 27 file://0002-readahead-chunk-on-spinning-media.patch \
28 file://0003-readahead-cleanups.patch \ 28 file://0003-readahead-cleanups.patch \
29 file://0013-systemd-sysctl-Handle-missing-etc-sysctl.conf-proper.patch \ 29 file://0013-systemd-sysctl-Handle-missing-etc-sysctl.conf-proper.patch \
30 file://0001-configure-use-AC_CHECK_TOOL-for-objcopy-strings-and-.patch \
30 file://199-firmware.patch \ 31 file://199-firmware.patch \
31 file://init \ 32 file://init \
32 " 33 "
@@ -77,6 +78,9 @@ EXTRA_OECONF_append_libc-uclibc = " --disable-myhostname "
77do_configure_prepend() { 78do_configure_prepend() {
78 export CPP="${HOST_PREFIX}cpp ${TOOLCHAIN_OPTIONS} ${HOST_CC_ARCH}" 79 export CPP="${HOST_PREFIX}cpp ${TOOLCHAIN_OPTIONS} ${HOST_CC_ARCH}"
79 80
81 export STRINGS = "${HOST_PREFIX}strings"
82 export GPERF = "${HOST_PREFIX}gperf"
83
80 sed -i -e 's:=/root:=${ROOT_HOME}:g' units/*.service* 84 sed -i -e 's:=/root:=${ROOT_HOME}:g' units/*.service*
81} 85}
82 86