summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-compat-units.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-12-13 19:36:23 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-28 00:52:35 +0000
commit4186d78d999b79571c884467f7dec1a0d96b4509 (patch)
treea2e54f54a033146e5c7e52f680a7a781f82948fd /meta/recipes-core/systemd/systemd-compat-units.bb
parent79f2bb474204b1c33d8c87892f42b3c3b4a20016 (diff)
downloadpoky-4186d78d999b79571c884467f7dec1a0d96b4509.tar.gz
systemd-compat-units: remove run-postints service
Remove this service as it's moved to the run-postinsts recipe. [YOCTO #5719] (From OE-Core rev: 1e3ac15fcf502396f92c69788642a56064e22e35) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd-compat-units.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-compat-units.bb19
1 files changed, 1 insertions, 18 deletions
diff --git a/meta/recipes-core/systemd/systemd-compat-units.bb b/meta/recipes-core/systemd/systemd-compat-units.bb
index d8cc3f7852..e653470821 100644
--- a/meta/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta/recipes-core/systemd/systemd-compat-units.bb
@@ -9,17 +9,7 @@ DEPENDS = "systemd-systemctl-native"
9 9
10inherit allarch 10inherit allarch
11 11
12SRC_URI = "file://*.service" 12ALLOW_EMPTY_${PN} = "1"
13
14do_install() {
15 install -d ${D}${systemd_unitdir}/system/basic.target.wants
16 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
17 sed -i -e 's,@POSTINSTALL_INITPOSITION@,${POSTINSTALL_INITPOSITION},g' \
18 ${WORKDIR}/run-postinsts.service
19 install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_unitdir}/system
20 ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/basic.target.wants/
21 ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/sysinit.target.wants/
22}
23 13
24SYSTEMD_DISABLED_SYSV_SERVICES = " \ 14SYSTEMD_DISABLED_SYSV_SERVICES = " \
25 busybox-udhcpc \ 15 busybox-udhcpc \
@@ -47,11 +37,4 @@ pkg_postinst_${PN} () {
47 done ; echo 37 done ; echo
48} 38}
49 39
50FILES_${PN} = "${systemd_unitdir}/system ${bindir}"
51RDPEPENDS_${PN} = "systemd" 40RDPEPENDS_${PN} = "systemd"
52
53# Define a variable to allow distros to run configure earlier.
54# (for example, to enable loading of ethernet kernel modules before networking starts)
55# note: modifying name or default value for POSTINSTALL_INITPOSITION requires
56# changes in opkg.inc
57POSTINSTALL_INITPOSITION ?= "98"