summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-bootconf_1.00.bb
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2018-02-28 18:15:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-06 06:35:42 -0800
commitb84b4223400d76a93b45b1b5f5ba0711d12366a8 (patch)
treee38d4c9156e267613c12c0efa1d50058cb6e68eb /meta/recipes-core/systemd/systemd-bootconf_1.00.bb
parentdbe0736341abf008e45558abc65b275a83fc9db9 (diff)
downloadpoky-b84b4223400d76a93b45b1b5f5ba0711d12366a8.tar.gz
systemd: add systemd-bootconf recipe
Reuses our systemd-boot-cfg bbclass to generate systemd-boot configuration files. (From OE-Core rev: 8bf86db982b4304c47b1d83ea8b2fc63eaa64b20) Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd-bootconf_1.00.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-bootconf_1.00.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-bootconf_1.00.bb b/meta/recipes-core/systemd/systemd-bootconf_1.00.bb
new file mode 100644
index 0000000000..e9c2466456
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd-bootconf_1.00.bb
@@ -0,0 +1,31 @@
1LICENSE = "MIT"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
3SUMMARY = "Basic systemd-boot configuration files"
4
5RPROVIDES_${PN} += "virtual/systemd-bootconf"
6
7inherit systemd-boot-cfg
8
9S = "${WORKDIR}"
10
11LABELS = "boot"
12
13ROOT ?= "root=/dev/sda2"
14APPEND_append = " ${ROOT}"
15
16python do_configure() {
17 bb.build.exec_func('build_efi_cfg', d)
18}
19
20do_configure[vardeps] += "APPEND"
21
22do_install() {
23 install -d ${D}/boot
24 install -d ${D}/boot/loader
25 install -d ${D}/boot/loader/entries
26 install loader.conf ${D}/boot/loader/
27 rm loader.conf
28 install *.conf ${D}/boot/loader/entries/
29}
30
31FILES_${PN} = "/boot/loader/* /boot/loader/entries/*"