summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-boot_247.2.bb
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@microsoft.com>2020-12-18 09:42:52 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-20 00:03:04 +0000
commit754d05fffebb69b6abcbe0cac39541aaee551f90 (patch)
tree1b74251f6b1edf0d1e77490112078b6a9349711d /meta/recipes-core/systemd/systemd-boot_247.2.bb
parentfae7b0ddba4836d7b1b1d642bd4514ceab50ca09 (diff)
downloadpoky-754d05fffebb69b6abcbe0cac39541aaee551f90.tar.gz
systemd: update 246 -> 247
Update systemd to v247.2. Add rule for new oomd dbus conf and for new pam.d conf directory in /usr/lib|lib64. Drop selinux-hook-handling-to-enumerate-nexthop.patch, merged upstream. Drop 0001-meson-Fix-reallocarray-check.patch, merged upstream. Refresh musl patches. (From OE-Core rev: 1e1d26de68ed13fd53c1a16b9662ac9860dca714) Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd-boot_247.2.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-boot_247.2.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_247.2.bb b/meta/recipes-core/systemd/systemd-boot_247.2.bb
new file mode 100644
index 0000000000..249e620f4e
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd-boot_247.2.bb
@@ -0,0 +1,70 @@
1require systemd.inc
2FILESEXTRAPATHS =. "${FILE_DIRNAME}/systemd:"
3
4require conf/image-uefi.conf
5
6DEPENDS = "intltool-native libcap util-linux gnu-efi gperf-native"
7
8inherit meson pkgconfig gettext
9inherit deploy
10
11LDFLAGS_prepend = "${@ " ".join(d.getVar('LD').split()[1:])} "
12
13do_write_config[vardeps] += "CC OBJCOPY"
14do_write_config_append() {
15 cat >${WORKDIR}/meson-${PN}.cross <<EOF
16[binaries]
17efi_cc = ${@meson_array('CC', d)}
18objcopy = ${@meson_array('OBJCOPY', d)}
19EOF
20}
21
22EXTRA_OEMESON += "-Defi=true \
23 -Dgnu-efi=true \
24 -Defi-includedir=${STAGING_INCDIR}/efi \
25 -Defi-libdir=${STAGING_LIBDIR} \
26 -Defi-ld=${@ d.getVar('LD').split()[0]} \
27 -Dman=false \
28 --cross-file ${WORKDIR}/meson-${PN}.cross \
29 "
30
31# install to the image as boot*.efi if its the EFI_PROVIDER,
32# otherwise install as the full name.
33# This allows multiple bootloaders to coexist in a single image.
34python __anonymous () {
35 import re
36 target = d.getVar('TARGET_ARCH')
37 prefix = "" if d.getVar('EFI_PROVIDER') == "systemd-boot" else "systemd-"
38 systemdimage = prefix + d.getVar("EFI_BOOT_IMAGE")
39 d.setVar("SYSTEMD_BOOT_IMAGE", systemdimage)
40 prefix = "systemd-" if prefix == "" else ""
41 d.setVar("SYSTEMD_BOOT_IMAGE_PREFIX", prefix)
42}
43
44FILES_${PN} = "${EFI_FILES_PATH}/${SYSTEMD_BOOT_IMAGE}"
45
46RDEPENDS_${PN} += "virtual/systemd-bootconf"
47
48# Imported from the old gummiboot recipe
49TUNE_CCARGS_remove = "-mfpmath=sse"
50
51COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
52COMPATIBLE_HOST_x86-x32 = "null"
53
54do_compile() {
55 ninja \
56 src/boot/efi/${SYSTEMD_BOOT_IMAGE_PREFIX}${SYSTEMD_BOOT_IMAGE} \
57 src/boot/efi/linux${EFI_ARCH}.efi.stub
58}
59
60do_install() {
61 install -d ${D}${EFI_FILES_PATH}
62 install ${B}/src/boot/efi/systemd-boot*.efi ${D}${EFI_FILES_PATH}/${SYSTEMD_BOOT_IMAGE}
63}
64
65do_deploy () {
66 install ${B}/src/boot/efi/systemd-boot*.efi ${DEPLOYDIR}
67 install ${B}/src/boot/efi/linux*.efi.stub ${DEPLOYDIR}
68}
69
70addtask deploy before do_build after do_compile