summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-boot_239.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2019-02-26 14:38:58 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-03 15:38:13 +0000
commit38cdb19deac1fdf21f494c0b61cf4eeaf48491eb (patch)
tree430281830ea214435390120317b7ebc11d3c4471 /meta/recipes-core/systemd/systemd-boot_239.bb
parent40bc0ed88062906c310642d4fb958d34d407e98e (diff)
downloadpoky-38cdb19deac1fdf21f494c0b61cf4eeaf48491eb.tar.gz
systemd-boot: upgrade to 241
The following two patches are added because I cannot figure out how to pass parameter to efi-cc if it's changed to be an array value. systemd/0001-Revert-meson-print-EFI-CC-configuration-nicely.patch systemd/0001-Revert-meson-use-an-array-option-for-efi-cc.patch (From OE-Core rev: 42ec27489135f5c2dbe708dacb5dadb0f5d9df5b) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd-boot_239.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-boot_239.bb70
1 files changed, 0 insertions, 70 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_239.bb b/meta/recipes-core/systemd/systemd-boot_239.bb
deleted file mode 100644
index 2450d52cb9..0000000000
--- a/meta/recipes-core/systemd/systemd-boot_239.bb
+++ /dev/null
@@ -1,70 +0,0 @@
1require systemd.inc
2FILESEXTRAPATHS =. "${FILE_DIRNAME}/systemd:"
3
4DEPENDS = "intltool-native libcap util-linux gnu-efi gperf-native"
5
6SRC_URI += "file://0002-use-lnr-wrapper-instead-of-looking-for-relative-opti.patch \
7 file://0006-remove-nobody-user-group-checking.patch \
8 file://0001-Fix-to-run-efi_cc-and-efi_ld-correctly-when-cross-co.patch \
9 file://0001-meson-rename-Ddebug-to-Ddebug-extra.patch \
10 "
11
12inherit meson pkgconfig gettext
13inherit deploy
14
15EFI_CC ?= "${CC}"
16EXTRA_OEMESON += "-Defi=true \
17 -Dgnu-efi=true \
18 -Defi-includedir=${STAGING_INCDIR}/efi \
19 -Defi-ldsdir=${STAGING_LIBDIR} \
20 -Defi-libdir=${STAGING_LIBDIR} \
21 -Dman=false \
22 -Defi-cc='${EFI_CC}' \
23 -Defi-ld='${LD}' \
24 "
25
26# install to the image as boot*.efi if its the EFI_PROVIDER,
27# otherwise install as the full name.
28# This allows multiple bootloaders to coexist in a single image.
29python __anonymous () {
30 import re
31 target = d.getVar('TARGET_ARCH')
32 prefix = "" if d.getVar('EFI_PROVIDER') == "systemd-boot" else "systemd-"
33 if target == "x86_64":
34 systemdimage = prefix + "bootx64.efi"
35 else:
36 systemdimage = prefix + "bootia32.efi"
37 d.setVar("SYSTEMD_BOOT_IMAGE", systemdimage)
38 prefix = "systemd-" if prefix == "" else ""
39 d.setVar("SYSTEMD_BOOT_IMAGE_PREFIX", prefix)
40}
41
42FILES_${PN} = "/boot/EFI/BOOT/${SYSTEMD_BOOT_IMAGE}"
43
44RDEPENDS_${PN} += "virtual/systemd-bootconf"
45
46# Imported from the old gummiboot recipe
47TUNE_CCARGS_remove = "-mfpmath=sse"
48COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
49COMPATIBLE_HOST_x86-x32 = "null"
50
51do_compile() {
52 SYSTEMD_BOOT_EFI_ARCH="ia32"
53 if [ "${TARGET_ARCH}" = "x86_64" ]; then
54 SYSTEMD_BOOT_EFI_ARCH="x64"
55 fi
56
57 ninja src/boot/efi/${SYSTEMD_BOOT_IMAGE_PREFIX}${SYSTEMD_BOOT_IMAGE}
58}
59
60do_install() {
61 install -d ${D}/boot
62 install -d ${D}/boot/EFI
63 install -d ${D}/boot/EFI/BOOT
64 install ${B}/src/boot/efi/systemd-boot*.efi ${D}/boot/EFI/BOOT/${SYSTEMD_BOOT_IMAGE}
65}
66
67do_deploy () {
68 install ${B}/src/boot/efi/systemd-boot*.efi ${DEPLOYDIR}
69}
70addtask deploy before do_build after do_compile