summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-boot_239.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-07-17 10:05:12 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-18 10:18:42 +0100
commitb0f2f690a3513e4c9fa30fee1b8d7ac2d7140657 (patch)
treec3d5512f0d5832c125b82f01d58b04c023b0973f /meta/recipes-core/systemd/systemd-boot_239.bb
parentada8a5d9175b141b4fe532f542f5c1f7ffa26d88 (diff)
downloadpoky-279bb1397697eab27356ddd8d953a1281014cff1.tar.gz
systemd-boot: upgrade to 2392.6_M2
Upgrade systemd-boot to 239. The following patch is removed due to recent fix about meson's cpu family mapping and validation. 0001-Also-check-i386-i586-and-i686-for-ia32.patch (From OE-Core rev: ff0b682b807959521c85716296de7a1d26d7d18f) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd-boot_239.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-boot_239.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_239.bb b/meta/recipes-core/systemd/systemd-boot_239.bb
new file mode 100644
index 0000000000..7fe420c262
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd-boot_239.bb
@@ -0,0 +1,69 @@
1require systemd.inc
2FILESEXTRAPATHS =. "${FILE_DIRNAME}/systemd:"
3
4DEPENDS = "intltool-native libcap util-linux gnu-efi gperf-native"
5
6SRC_URI += "file://0002-use-lnr-wrapper-instead-of-looking-for-relative-opti.patch \
7 file://0006-remove-nobody-user-group-checking.patch \
8 file://0001-Fix-to-run-efi_cc-and-efi_ld-correctly-when-cross-co.patch \
9 "
10
11inherit meson pkgconfig gettext
12inherit deploy
13
14EFI_CC ?= "${CC}"
15EXTRA_OEMESON += "-Defi=true \
16 -Dgnu-efi=true \
17 -Defi-includedir=${STAGING_INCDIR}/efi \
18 -Defi-ldsdir=${STAGING_LIBDIR} \
19 -Defi-libdir=${STAGING_LIBDIR} \
20 -Dman=false \
21 -Defi-cc='${EFI_CC}' \
22 -Defi-ld='${LD}' \
23 "
24
25# install to the image as boot*.efi if its the EFI_PROVIDER,
26# otherwise install as the full name.
27# This allows multiple bootloaders to coexist in a single image.
28python __anonymous () {
29 import re
30 target = d.getVar('TARGET_ARCH')
31 prefix = "" if d.getVar('EFI_PROVIDER', True) == "systemd-boot" else "systemd-"
32 if target == "x86_64":
33 systemdimage = prefix + "bootx64.efi"
34 else:
35 systemdimage = prefix + "bootia32.efi"
36 d.setVar("SYSTEMD_BOOT_IMAGE", systemdimage)
37 prefix = "systemd-" if prefix == "" else ""
38 d.setVar("SYSTEMD_BOOT_IMAGE_PREFIX", prefix)
39}
40
41FILES_${PN} = "/boot/EFI/BOOT/${SYSTEMD_BOOT_IMAGE}"
42
43RDEPENDS_${PN} += "virtual/systemd-bootconf"
44
45# Imported from the old gummiboot recipe
46TUNE_CCARGS_remove = "-mfpmath=sse"
47COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
48COMPATIBLE_HOST_x86-x32 = "null"
49
50do_compile() {
51 SYSTEMD_BOOT_EFI_ARCH="ia32"
52 if [ "${TARGET_ARCH}" = "x86_64" ]; then
53 SYSTEMD_BOOT_EFI_ARCH="x64"
54 fi
55
56 ninja src/boot/efi/${SYSTEMD_BOOT_IMAGE_PREFIX}${SYSTEMD_BOOT_IMAGE}
57}
58
59do_install() {
60 install -d ${D}/boot
61 install -d ${D}/boot/EFI
62 install -d ${D}/boot/EFI/BOOT
63 install ${B}/src/boot/efi/systemd-boot*.efi ${D}/boot/EFI/BOOT/${SYSTEMD_BOOT_IMAGE}
64}
65
66do_deploy () {
67 install ${B}/src/boot/efi/systemd-boot*.efi ${DEPLOYDIR}
68}
69addtask deploy before do_build after do_compile