summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-18 15:14:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-23 11:57:25 +0100
commit86d30d756a60d181a95cf07041920a367a0cd0ba (patch)
tree950353e2e1cd1e7b812ff941b4d06076acd2c752 /meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
parentf98c8490099a02c42306e1671579631a61c9df73 (diff)
downloadpoky-86d30d756a60d181a95cf07041920a367a0cd0ba.tar.gz
meta: Add explict getVar param for (non) expansion
Rather than just use d.getVar(X), use the more explict d.getVar(X, False) since at some point in the future, having the default of expansion would be nice. This is the first step towards that. This patch was mostly made using the command: sed -e 's:\(getVar([^,()]*\)\s*):\1, False):g' -i `grep -ril getVar *` (From OE-Core rev: ab7c1d239b122c8e549e8112c88fd46c9e2b061b) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-sdk.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-sdk.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
index 9b26387e44..5b11861d91 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
@@ -71,9 +71,9 @@ RRECOMMENDS_packagegroup-core-sdk = "\
71# if packaged('%s-dev' % name, d): 71# if packaged('%s-dev' % name, d):
72# rreclist.append('%s-dev' % name) 72# rreclist.append('%s-dev' % name)
73# 73#
74# oldrrec = d.getVar('RRECOMMENDS_%s' % newpkg) or '' 74# oldrrec = d.getVar('RRECOMMENDS_%s' % newpkg, False) or ''
75# d.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist)) 75# d.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist))
76# # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, d.getVar('RRECOMMENDS_%s' % newpkg))) 76# # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, d.getVar('RRECOMMENDS_%s' % newpkg, False)))
77# 77#
78# # bb.note('pkgs is %s' % pkgs) 78# # bb.note('pkgs is %s' % pkgs)
79# d.setVar('PACKAGES', ' '.join(pkgs)) 79# d.setVar('PACKAGES', ' '.join(pkgs))