summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-29 11:38:34 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 12:52:55 +0100
commit272cb74d70686cb7f72005dc25e02f38b46ecd57 (patch)
tree3a5e4cb0c9a2e407b2d04c78b1eb51d0f429ca64 /meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
parentf1df3f828bfc9e70bf8cf5a7c2e2cf216944785a (diff)
downloadpoky-272cb74d70686cb7f72005dc25e02f38b46ecd57.tar.gz
Rename task to packagegroup
"Package group" is a much more appropriate name for these than task, since we use the word task to describe units of work executed by BitBake. (From OE-Core rev: 424dcf7046e4ad09dcc664eb1992201195247fcf) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-sdk.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-sdk.bb94
1 files changed, 94 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
new file mode 100644
index 0000000000..663f7057de
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
@@ -0,0 +1,94 @@
1#
2# Copyright (C) 2007 OpenedHand Ltd.
3#
4
5DESCRIPTION = "Software Development Tasks for OpenedHand Poky"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9DEPENDS = "packagegroup-core-console"
10PR = "r8"
11
12ALLOW_EMPTY = "1"
13#PACKAGEFUNCS =+ 'generate_sdk_pkgs'
14
15PACKAGES = "\
16 packagegroup-core-sdk \
17 packagegroup-core-sdk-dbg \
18 packagegroup-core-sdk-dev"
19
20RDEPENDS_packagegroup-core-sdk = "\
21 autoconf \
22 automake \
23 binutils \
24 binutils-symlinks \
25 coreutils \
26 cpp \
27 cpp-symlinks \
28 ccache \
29 diffutils \
30 gcc \
31 gcc-symlinks \
32 g++ \
33 g++-symlinks \
34 gettext \
35 make \
36 intltool \
37 libstdc++ \
38 libstdc++-dev \
39 libtool \
40 perl-module-re \
41 perl-module-text-wrap \
42 pkgconfig \
43 findutils \
44 quilt \
45 less \
46 distcc \
47 ldd \
48 file \
49 tcl"
50
51RRECOMMENDS_packagegroup-core-sdk = "\
52 libgomp \
53 libgomp-dev"
54
55#python generate_sdk_pkgs () {
56# poky_pkgs = read_pkgdata('packagegroup-core', d)['PACKAGES']
57# pkgs = d.getVar('PACKAGES', True).split()
58# for pkg in poky_pkgs.split():
59# newpkg = pkg.replace('packagegroup-core', 'packagegroup-core-sdk')
60#
61# # for each of the task packages, add a corresponding sdk task
62# pkgs.append(newpkg)
63#
64# # for each sdk task, take the rdepends of the non-sdk task, and turn
65# # that into rrecommends upon the -dev versions of those, not unlike
66# # the package depchain code
67# spkgdata = read_subpkgdata(pkg, d)
68#
69# rdepends = explode_deps(spkgdata.get('RDEPENDS_%s' % pkg) or '')
70# rreclist = []
71#
72# for depend in rdepends:
73# split_depend = depend.split(' (')
74# name = split_depend[0].strip()
75# if packaged('%s-dev' % name, d):
76# rreclist.append('%s-dev' % name)
77# else:
78# deppkgdata = read_subpkgdata(name, d)
79# rdepends2 = explode_deps(deppkgdata.get('RDEPENDS_%s' % name) or '')
80# for depend in rdepends2:
81# split_depend = depend.split(' (')
82# name = split_depend[0].strip()
83# if packaged('%s-dev' % name, d):
84# rreclist.append('%s-dev' % name)
85#
86# oldrrec = d.getVar('RRECOMMENDS_%s' % newpkg) or ''
87# d.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist))
88# # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, d.getVar('RRECOMMENDS_%s' % newpkg)))
89#
90# # bb.note('pkgs is %s' % pkgs)
91# d.setVar('PACKAGES', ' '.join(pkgs))
92#}
93#
94#PACKAGES_DYNAMIC = "packagegroup-core-sdk-*"