summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-09-24 19:54:42 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-18 12:13:13 +0100
commitbf97b1a311b2621be9da6b4e5611fca6444e4c27 (patch)
treeacea06cb7cdad829113ceae0471cd3a896d240ea /meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb
parentbf3b8506a1c864f7547f08d87386f88ed700ed14 (diff)
downloadpoky-bf97b1a311b2621be9da6b4e5611fca6444e4c27.tar.gz
Add packagegroup-core-buildessential
[Not heavily tested, but sent for discussion] task-core-sdk is too big - for example, I simply don't want to ship tcl, ever =) Historically distcc caused a large dependency graph explosion because it has a utility which uses gtk+, although that was fixed. packagegroup-core-sdk also includes coreutils, which is a bit confusing; conceptually things dependent on coreutils should pull it in explicitly, or possibly we just declare coreutils to be in the minimal build set. So packagegroup-core-buildessential is intended to be similar to Debian's "build-essential" package. It's the stuff needed by say 80+% of components, not worth repeating over and over. (From OE-Core rev: 7d6cc169c95fecf6388a275281eb8b8f5d8eb4a2) Signed-off-by: Colin Walters <walters@verbum.org> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb b/meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb
new file mode 100644
index 0000000000..164da36686
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb
@@ -0,0 +1,30 @@
1#
2# Copyright (C) 2007 OpenedHand Ltd.
3# Copyright (C) 2012 Red Hat, Inc.
4#
5
6SUMMARY = "Essential build dependencies"
7LICENSE = "MIT"
8PR = "r0"
9
10inherit packagegroup
11
12RDEPENDS_packagegroup-core-buildessential = "\
13 autoconf \
14 automake \
15 binutils \
16 binutils-symlinks \
17 cpp \
18 cpp-symlinks \
19 gcc \
20 gcc-symlinks \
21 g++ \
22 g++-symlinks \
23 gettext \
24 make \
25 libstdc++ \
26 libstdc++-dev \
27 libtool \
28 pkgconfig \
29 "
30