summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ovmf/ovmf_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 15:44:10 +0100
commitbb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch)
tree76e376b01253c3aace1a98a5021bcaad3c92e861 /meta/recipes-core/ovmf/ovmf_git.bb
parentfcc456ee4b8f619134abb4649db53c638074082c (diff)
downloadpoky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". (From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/ovmf/ovmf_git.bb')
-rw-r--r--meta/recipes-core/ovmf/ovmf_git.bb28
1 files changed, 14 insertions, 14 deletions
diff --git a/meta/recipes-core/ovmf/ovmf_git.bb b/meta/recipes-core/ovmf/ovmf_git.bb
index 90dae2aed0..145240e77e 100644
--- a/meta/recipes-core/ovmf/ovmf_git.bb
+++ b/meta/recipes-core/ovmf/ovmf_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "OVMF is an EDK II based project to enable UEFI support for \
3Virtual Machines. OVMF contains sample UEFI firmware for QEMU and KVM" 3Virtual Machines. OVMF contains sample UEFI firmware for QEMU and KVM"
4HOMEPAGE = "https://github.com/tianocore/tianocore.github.io/wiki/OVMF" 4HOMEPAGE = "https://github.com/tianocore/tianocore.github.io/wiki/OVMF"
5LICENSE = "BSD-2-Clause" 5LICENSE = "BSD-2-Clause"
6LICENSE_class-target = "${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'BSD & OpenSSL', 'BSD', d)}" 6LICENSE:class-target = "${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'BSD & OpenSSL', 'BSD', d)}"
7LIC_FILES_CHKSUM = "file://OvmfPkg/License.txt;md5=06357ddc23f46577c2aeaeaf7b776d65" 7LIC_FILES_CHKSUM = "file://OvmfPkg/License.txt;md5=06357ddc23f46577c2aeaeaf7b776d65"
8 8
9# Enabling Secure Boot adds a dependency on OpenSSL and implies 9# Enabling Secure Boot adds a dependency on OpenSSL and implies
@@ -40,7 +40,7 @@ EDK_TOOLS_DIR="edk2_basetools"
40BUILD_OPTIMIZATION="-pipe" 40BUILD_OPTIMIZATION="-pipe"
41 41
42# OVMF supports IA only, although it could conceivably support ARM someday. 42# OVMF supports IA only, although it could conceivably support ARM someday.
43COMPATIBLE_HOST_class-target='(i.86|x86_64).*' 43COMPATIBLE_HOST:class-target='(i.86|x86_64).*'
44 44
45# Additional build flags for OVMF with Secure Boot. 45# Additional build flags for OVMF with Secure Boot.
46# Fedora also uses "-D SMM_REQUIRE -D EXCLUDE_SHELL_FROM_FD". 46# Fedora also uses "-D SMM_REQUIRE -D EXCLUDE_SHELL_FROM_FD".
@@ -52,7 +52,7 @@ export PYTHON_COMMAND = "${HOSTTOOLS_DIR}/python3"
52do_patch[postfuncs] += "fix_basetools_location" 52do_patch[postfuncs] += "fix_basetools_location"
53fix_basetools_location () { 53fix_basetools_location () {
54} 54}
55fix_basetools_location_class-target() { 55fix_basetools_location:class-target() {
56 # Replaces the fake path inserted by 0002-ovmf-update-path-to-native-BaseTools.patch. 56 # Replaces the fake path inserted by 0002-ovmf-update-path-to-native-BaseTools.patch.
57 # Necessary for finding the actual BaseTools from ovmf-native. 57 # Necessary for finding the actual BaseTools from ovmf-native.
58 sed -i -e 's#BBAKE_EDK_TOOLS_PATH#${STAGING_BINDIR_NATIVE}/${EDK_TOOLS_DIR}#' ${S}/OvmfPkg/build.sh 58 sed -i -e 's#BBAKE_EDK_TOOLS_PATH#${STAGING_BINDIR_NATIVE}/${EDK_TOOLS_DIR}#' ${S}/OvmfPkg/build.sh
@@ -61,7 +61,7 @@ fix_basetools_location_class-target() {
61do_patch[postfuncs] += "fix_iasl" 61do_patch[postfuncs] += "fix_iasl"
62fix_iasl() { 62fix_iasl() {
63} 63}
64fix_iasl_class-native() { 64fix_iasl:class-native() {
65 # iasl is not installed under /usr/bin when building with OE. 65 # iasl is not installed under /usr/bin when building with OE.
66 sed -i -e 's#/usr/bin/iasl#${STAGING_BINDIR_NATIVE}/iasl#' ${S}/BaseTools/Conf/tools_def.template 66 sed -i -e 's#/usr/bin/iasl#${STAGING_BINDIR_NATIVE}/iasl#' ${S}/BaseTools/Conf/tools_def.template
67} 67}
@@ -80,14 +80,14 @@ fix_toolchain() {
80 -e '/^VFR_CPPFLAGS/a CC = ${CC}\nCXX = ${CXX}\nAS = ${AS}\nAR = ${AR}\nLD = ${LD}' \ 80 -e '/^VFR_CPPFLAGS/a CC = ${CC}\nCXX = ${CXX}\nAS = ${AS}\nAR = ${AR}\nLD = ${LD}' \
81 ${S}/BaseTools/Source/C/VfrCompile/GNUmakefile 81 ${S}/BaseTools/Source/C/VfrCompile/GNUmakefile
82} 82}
83fix_toolchain_append_class-native() { 83fix_toolchain:append:class-native() {
84 # This tools_def.template is going to be used by the target ovmf and 84 # This tools_def.template is going to be used by the target ovmf and
85 # defines which compilers to use. For the GCC toolchain definitions, 85 # defines which compilers to use. For the GCC toolchain definitions,
86 # that will be ${HOST_PREFIX}gcc. However, "make" doesn't need that 86 # that will be ${HOST_PREFIX}gcc. However, "make" doesn't need that
87 # prefix. 87 # prefix.
88 # 88 #
89 # Injecting ENV(HOST_PREFIX) matches exporting that value as env 89 # Injecting ENV(HOST_PREFIX) matches exporting that value as env
90 # variable in do_compile_class-target. 90 # variable in do_compile:class-target.
91 sed -i \ 91 sed -i \
92 -e 's#\(ENV\|DEF\)(GCC.*_PREFIX)#ENV(HOST_PREFIX)#' \ 92 -e 's#\(ENV\|DEF\)(GCC.*_PREFIX)#ENV(HOST_PREFIX)#' \
93 -e 's#ENV(HOST_PREFIX)make#make#' \ 93 -e 's#ENV(HOST_PREFIX)make#make#' \
@@ -150,11 +150,11 @@ fixup_target_tools() {
150 echo ${FIXED_GCCVER} 150 echo ${FIXED_GCCVER}
151} 151}
152 152
153do_compile_class-native() { 153do_compile:class-native() {
154 oe_runmake -C ${S}/BaseTools 154 oe_runmake -C ${S}/BaseTools
155} 155}
156 156
157do_compile_class-target() { 157do_compile:class-target() {
158 export LFLAGS="${LDFLAGS}" 158 export LFLAGS="${LDFLAGS}"
159 PARALLEL_JOBS="${@oe.utils.parallel_make_argument(d, '-n %d')}" 159 PARALLEL_JOBS="${@oe.utils.parallel_make_argument(d, '-n %d')}"
160 OVMF_ARCH="X64" 160 OVMF_ARCH="X64"
@@ -203,12 +203,12 @@ do_compile_class-target() {
203 fi 203 fi
204} 204}
205 205
206do_install_class-native() { 206do_install:class-native() {
207 install -d ${D}/${bindir}/edk2_basetools 207 install -d ${D}/${bindir}/edk2_basetools
208 cp -r ${S}/BaseTools ${D}/${bindir}/${EDK_TOOLS_DIR} 208 cp -r ${S}/BaseTools ${D}/${bindir}/${EDK_TOOLS_DIR}
209} 209}
210 210
211do_install_class-target() { 211do_install:class-target() {
212 # Content for UEFI shell iso. We install the EFI shell as 212 # Content for UEFI shell iso. We install the EFI shell as
213 # bootx64/ia32.efi because then it can be started even when the 213 # bootx64/ia32.efi because then it can be started even when the
214 # firmware itself does not contain it. 214 # firmware itself does not contain it.
@@ -225,19 +225,19 @@ do_install_class-target() {
225# 225#
226# However, EnrollDefaultKeys.efi is only included when Secure Boot is enabled. 226# However, EnrollDefaultKeys.efi is only included when Secure Boot is enabled.
227PACKAGES =+ "ovmf-shell-efi" 227PACKAGES =+ "ovmf-shell-efi"
228FILES_ovmf-shell-efi = " \ 228FILES:ovmf-shell-efi = " \
229 EnrollDefaultKeys.efi \ 229 EnrollDefaultKeys.efi \
230 efi/ \ 230 efi/ \
231" 231"
232 232
233DEPLOYDEP = "" 233DEPLOYDEP = ""
234DEPLOYDEP_class-target = "qemu-system-native:do_populate_sysroot" 234DEPLOYDEP:class-target = "qemu-system-native:do_populate_sysroot"
235DEPLOYDEP_class-target += " ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'openssl-native:do_populate_sysroot', '', d)}" 235DEPLOYDEP:class-target += " ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'openssl-native:do_populate_sysroot', '', d)}"
236do_deploy[depends] += "${DEPLOYDEP}" 236do_deploy[depends] += "${DEPLOYDEP}"
237 237
238do_deploy() { 238do_deploy() {
239} 239}
240do_deploy_class-target() { 240do_deploy:class-target() {
241 # For use with "runqemu ovmf". 241 # For use with "runqemu ovmf".
242 for i in \ 242 for i in \
243 ovmf \ 243 ovmf \