summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/newlib/newlib_git.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez Samaniego <alejandro@enedino.org>2023-01-27 12:43:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-29 19:24:22 +0000
commitf3ad36d15ccb88f89cb0621593b69b63b47a5358 (patch)
tree641493cf0c95a790b9bc06f95794bbb94b118ff4 /meta/recipes-core/newlib/newlib_git.bb
parentfa4cd1a7a20615c228a5556e135ddf791d28b8a0 (diff)
downloadpoky-f3ad36d15ccb88f89cb0621593b69b63b47a5358.tar.gz
newlib: Upgrade 4.2.0 -> 4.3.0
- Rebased fix-rs6000-crt0.patch - Patch fix_makefile_include_arm_h.patch is no longer required, the newlib header dependency has been fixed upstream at 26f9cfd7 - LICENSE checksum change due to: - Adding SPDX identifier - Deleted Phoenix Systems from License and updated each licenses numbers accordingly. - Add a dummy limits.h header, to make the improved preprocessor checks happy during configure. - Add a patch for libgloss to maintain current behavior of TCLIBC=newlib by making libgloss DEPEND on newlib and use its installed headers. - Switch to git fetcher to simplify fetching the sources and avoid future issues due to the way newlib release snapshots were being published. (From OE-Core rev: 1c9cbb27dfe37ca4574c4285fb03ce394dee5ed1) Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/newlib/newlib_git.bb')
-rw-r--r--meta/recipes-core/newlib/newlib_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-core/newlib/newlib_git.bb b/meta/recipes-core/newlib/newlib_git.bb
new file mode 100644
index 0000000000..fb922d65d1
--- /dev/null
+++ b/meta/recipes-core/newlib/newlib_git.bb
@@ -0,0 +1,20 @@
1require newlib.inc
2
3PROVIDES += "virtual/libc virtual/libiconv virtual/libintl"
4
5do_configure() {
6 export CC_FOR_TARGET="${CC}"
7 ${S}/configure ${EXTRA_OECONF}
8}
9
10do_install:append() {
11 # Move include files and libs to default directories so they can be picked up later
12 mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
13 mv -v ${D}${prefix}/${TARGET_SYS}/include ${D}${includedir}
14
15 # Remove original directory
16 rmdir ${D}${prefix}/${TARGET_SYS}
17}
18
19# No rpm package is actually created but -dev depends on it, avoid dnf error
20DEV_PKG_DEPENDENCY:libc-newlib = ""