summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/newlib/newlib_3.2.0.bb
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandro@enedino.org>2020-01-15 09:11:46 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-19 13:24:38 +0000
commit1f3066006a9c4949b8b37dac5bcf73f91f8ba825 (patch)
tree981d1ccfc62c6fb2ca0d7963413c7efbce564352 /meta/recipes-core/newlib/newlib_3.2.0.bb
parentb51f67303c14aef3cab7a91b22822db8244a576f (diff)
downloadpoky-1f3066006a9c4949b8b37dac5bcf73f91f8ba825.tar.gz
newlib: Upgrade newlib and libgloss to the yearly release 3.2.0
A new yearly snapshot was taken on January 2nd of 2020, this bumps newlib to 3.2.0. - Mentor Graphics added tcl license (amdgcn-* targets) - BSD-Clause-2 was added as well by Dinux (pru-* targets) (From OE-Core rev: e2d0e36234ba928d0cbcc98d8358b94d8d44412e) Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/newlib/newlib_3.2.0.bb')
-rw-r--r--meta/recipes-core/newlib/newlib_3.2.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-core/newlib/newlib_3.2.0.bb b/meta/recipes-core/newlib/newlib_3.2.0.bb
new file mode 100644
index 0000000000..7ab5b2b94e
--- /dev/null
+++ b/meta/recipes-core/newlib/newlib_3.2.0.bb
@@ -0,0 +1,20 @@
1require newlib.inc
2
3PROVIDES += "virtual/libc virtual/libiconv virtual/libintl"
4
5do_configure() {
6 export CC_FOR_TARGET="${CC}"
7 ${S}/configure ${EXTRA_OECONF}
8}
9
10do_install_append() {
11 # Move include files and libs to default directories so they can be picked up later
12 mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
13 mv -v ${D}${prefix}/${TARGET_SYS}/include ${D}${includedir}
14
15 # Remove original directory
16 rmdir ${D}${prefix}/${TARGET_SYS}
17}
18
19# No rpm package is actually created but -dev depends on it, avoid dnf error
20RDEPENDS_${PN}-dev_libc-newlib = ""