summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/newlib/libgloss_3.2.0.bb
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandro@enedino.org>2020-01-15 09:11:46 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-19 13:24:38 +0000
commit1f3066006a9c4949b8b37dac5bcf73f91f8ba825 (patch)
tree981d1ccfc62c6fb2ca0d7963413c7efbce564352 /meta/recipes-core/newlib/libgloss_3.2.0.bb
parentb51f67303c14aef3cab7a91b22822db8244a576f (diff)
downloadpoky-1f3066006a9c4949b8b37dac5bcf73f91f8ba825.tar.gz
newlib: Upgrade newlib and libgloss to the yearly release 3.2.0
A new yearly snapshot was taken on January 2nd of 2020, this bumps newlib to 3.2.0. - Mentor Graphics added tcl license (amdgcn-* targets) - BSD-Clause-2 was added as well by Dinux (pru-* targets) (From OE-Core rev: e2d0e36234ba928d0cbcc98d8358b94d8d44412e) Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/newlib/libgloss_3.2.0.bb')
-rw-r--r--meta/recipes-core/newlib/libgloss_3.2.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/newlib/libgloss_3.2.0.bb b/meta/recipes-core/newlib/libgloss_3.2.0.bb
new file mode 100644
index 0000000000..c9ed30d988
--- /dev/null
+++ b/meta/recipes-core/newlib/libgloss_3.2.0.bb
@@ -0,0 +1,33 @@
1require newlib.inc
2
3DEPENDS += "newlib"
4
5FILESEXTRAPATHS_prepend := "${THISDIR}/libgloss:"
6
7SRC_URI_append_powerpc = " file://fix-rs6000-crt0.patch"
8SRC_URI_append_arm = " file://fix_makefile_include_arm_h.patch"
9
10do_configure() {
11 ${S}/libgloss/configure ${EXTRA_OECONF}
12}
13
14do_install_prepend() {
15 # install doesn't create this itself, avoid install error
16 install -d ${D}${prefix}/${TARGET_SYS}/lib
17}
18
19do_install_append() {
20 # Move libs to default directories so they can be picked up later
21 install -d ${D}${libdir}
22 mv -v ${D}${prefix}/${TARGET_SYS}/lib/* ${D}${libdir}
23
24 # Remove original directory
25 rmdir -p --ignore-fail-on-non-empty ${D}${prefix}/${TARGET_SYS}/lib
26}
27
28# Split packages correctly
29FILES_${PN} += "${libdir}/*.ld ${libdir}/*.specs"
30FILES_${PN}-dev += "${libdir}/cpu-init/*"
31
32INHIBIT_PACKAGE_STRIP = "1"
33INHIBIT_PACKAGE_DEBUG_SPLIT = "1"