summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/netbase/netbase_6.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-04 21:07:14 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-09 12:20:32 +0000
commitba069a5a3dae374744f68a57ab9e7869167beb2b (patch)
tree692fac1a8128486e1c58592401b1fe6cb8723e56 /meta/recipes-core/netbase/netbase_6.2.bb
parent1c3e8209f83a2c842954e22d92b8194de299a05b (diff)
downloadpoky-ba069a5a3dae374744f68a57ab9e7869167beb2b.tar.gz
netbase: upgrade 6.1 -> 6.2
Not sure why this didn't inherit allarch, but now it does - only static data is installed. (From OE-Core rev: ae1880436b293449318655f5b0207d2a741052ba) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/netbase/netbase_6.2.bb')
-rw-r--r--meta/recipes-core/netbase/netbase_6.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-core/netbase/netbase_6.2.bb b/meta/recipes-core/netbase/netbase_6.2.bb
new file mode 100644
index 0000000000..a54d2e7764
--- /dev/null
+++ b/meta/recipes-core/netbase/netbase_6.2.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Basic TCP/IP networking support"
2DESCRIPTION = "This package provides the necessary infrastructure for basic TCP/IP based networking"
3HOMEPAGE = "http://packages.debian.org/netbase"
4SECTION = "base"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://debian/copyright;md5=3dd6192d306f582dee7687da3d8748ab"
7PE = "1"
8
9SRC_URI = "${DEBIAN_MIRROR}/main/n/${BPN}/${BPN}_${PV}.tar.xz"
10
11inherit allarch
12
13SRC_URI[sha256sum] = "309a24146a06347d654b261e9e07a82fab844b173674a42e223803dd8258541e"
14
15UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/n/netbase/"
16
17do_install () {
18 install -d ${D}${sysconfdir}
19 install -m 0644 ${S}/etc/rpc ${D}${sysconfdir}/rpc
20 install -m 0644 ${S}/etc/protocols ${D}${sysconfdir}/protocols
21 install -m 0644 ${S}/etc/services ${D}${sysconfdir}/services
22 install -m 0644 ${S}/etc/ethertypes ${D}${sysconfdir}/ethertypes
23}