summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/musl_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-12-12 16:34:01 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-15 22:51:56 +0000
commitd6eac97c3a56885987d618aebd26750ece3868d3 (patch)
treeb0a7ab4a34544289b162406da41380e2c9136cd8 /meta/recipes-core/musl/musl_git.bb
parent5bc29f4995163122098edd0a22994249d87610e7 (diff)
downloadpoky-d6eac97c3a56885987d618aebd26750ece3868d3.tar.gz
musl: Update to latest master
Refresh patches to apply to this update Brings in following fixes * 1e4204d5 use libc-internal malloc for newlocale/freelocale * 36246b34 drop use of pthread_once in newlocale * 37fcc13c lift locale lock out of internal __get_locale * c53e9b23 fix misleading comment in strstr * b67d56c7 drop use of pthread_once for aio thread stack size init * 90ff0169 fix omission of non-stub pthread_mutexattr_getprotocol * 56f0631d riscv64: fix inconsistent ucontext_t struct tag * 50c7935c fix failure to preserve r6 in s390x asm; per ABI it is call-saved * 738c4e94 s390x: derive float_t from compiler or default to float * 821083ac implement reallocarray * 29ff7599 implement realpath directly instead of using procfs readlink * 5d464f52 fix mallocng regression in malloc_usable_size with null argument * d046ec92 configure: do not use obsolescent form of test -a|o * c5d118eb fix segfault in lutimes when tv argument is NULL * 67f77462 netinet/in.h: add IP_RECVERR_4884 from linux v5.9 * d078f836 sys/fanotify.h: add new FAN_* macros from linux v5.9 * 3ba370fe bits/syscall.h: add __NR_close_range from linux v5.9 * badc5bb2 add missing personality values * 6e989248 arm fabs and sqrt: support single-precision-only fpu variants * c8c3e341 fix typo in INSTALL * e2fa720b work around linux bug in readlink syscall with zero buffer size * c17cda6d parse v3 or future-unknown zoneinfo file versions as v2+ * 585a0a78 explicitly prefer 64-bit/v2 zoneinfo tables * debbddf7 fix regression in pthread_exit * 3ab2a4e0 rewrite wcsnrtombs to fix buffer overflow and other bugs * 233bb697 protect destruction of process-shared mutexes against robust list races * d26e0774 pthread_exit: don't __vm_wait under thread list lock * 167390f0 lift child restrictions after multi-threaded fork * 34952fe5 convert malloc use under libc-internal locks to use internal allocator * 8d37958d give libc access to its own malloc even if public malloc is interposed * c1e5d243 drop use of getdelim/stdio in dynamic linker * cbecda0b dlerror: don't gratuitously hold freebuf_queue lock while freeing * 4ffa7068 fix vector types in aarch64 register file structures (From OE-Core rev: b70b875c2f405f6481b1179419cf0f086fa31f53) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/musl/musl_git.bb')
-rw-r--r--meta/recipes-core/musl/musl_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 23c2072ea3..d4e75f9185 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@
4require musl.inc 4require musl.inc
5inherit linuxloader 5inherit linuxloader
6 6
7SRCREV = "d91a6cf6e369a79587c5665fce9635e5634ca201" 7SRCREV = "1e4204d522670a1d8b8ab85f1cfefa960547e8af"
8 8
9BASEVER = "1.2.1" 9BASEVER = "1.2.1"
10 10