summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/libc-test_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-09-08 18:56:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-11 16:04:35 +0100
commita1b3e8758eca008c2d8e05ece0a121d6509dfa78 (patch)
tree38a4ab63f9542654412cb3c2540e479475d865ae /meta/recipes-core/musl/libc-test_git.bb
parent14a6dc7c0510d7b47e084fa63c168ce771572247 (diff)
downloadpoky-a1b3e8758eca008c2d8e05ece0a121d6509dfa78.tar.gz
libc-test: Run as non-root user
Some of tests impose rlimit on it before running which wont be imposed when running as root user. Fixes src/regression/pthread_atfork-errno-clobber.c:23: (pid = fork()) == -1 failed: fork succeeded despite rlimit src/regression/pthread_atfork-errno-clobber.c:23: (pid = fork()) == -1 failed: fork succeeded despite rlimit FAIL src/regression/pthread_atfork-errno-clobber-static.exe [status 1] (From OE-Core rev: 585bf4b780a8ad60ba2b33cede4f0092ff61ddfc) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/musl/libc-test_git.bb')
-rw-r--r--meta/recipes-core/musl/libc-test_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/musl/libc-test_git.bb b/meta/recipes-core/musl/libc-test_git.bb
index e63abe838d..619a959fd2 100644
--- a/meta/recipes-core/musl/libc-test_git.bb
+++ b/meta/recipes-core/musl/libc-test_git.bb
@@ -13,6 +13,7 @@ SRCREV = "18e28496adee3d84fefdda6efcb9c5b8996a2398"
13SRC_URI = " \ 13SRC_URI = " \
14 git://repo.or.cz/libc-test;branch=master;protocol=https \ 14 git://repo.or.cz/libc-test;branch=master;protocol=https \
15 file://run-ptest \ 15 file://run-ptest \
16 file://run-libc-ptests \
16" 17"
17 18
18PV = "0+git" 19PV = "0+git"
@@ -48,5 +49,9 @@ do_install () {
48 cp -r ${S}/src ${D}${install_path} 49 cp -r ${S}/src ${D}${install_path}
49} 50}
50 51
52do_install_ptest_base:append() {
53 install -Dm 0755 ${WORKDIR}/run-libc-ptests ${D}${PTEST_PATH}/run-libc-ptests
54}
55
51COMPATIBLE_HOST = "null" 56COMPATIBLE_HOST = "null"
52COMPATIBLE_HOST:libc-musl = "(.*)" 57COMPATIBLE_HOST:libc-musl = "(.*)"