summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/uninative-tarball.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-28 10:10:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-23 20:31:18 +0100
commit2cbab459e471abbddba8badc64805e7226e864be (patch)
tree1005e79daebb1f6cba2ef6258da00995e2572263 /meta/recipes-core/meta/uninative-tarball.bb
parenta94574f189a2840ddb9cf78c050384d4c833d291 (diff)
downloadpoky-2cbab459e471abbddba8badc64805e7226e864be.tar.gz
uninative: Add uninative - a way of reusing native/cross over multiple distros
These patches are the start of a new idea, a way of allowing a single set of cross/native sstate to work over mutliple distros, even old ones. The assumption is that our own C library is basically up to date. We build and share a small tarball (~2MB) of a prebuilt copy of this along with a patchelf binary (which sadly is C++ based so libstdc++ is in there). This tarball can be generated from our usual SDK generation process through the supplied recipe, uninative-tarball. At the start of the build, if its not been extracted into the sysroot, this tarball is extracted there and configured for the specified path. When we install binaries from a "uninative" sstate feed, we change the dynamic loader to point at this dynamic loader and C librbary. This works exactly the same way as our relocatable SDK does. The only real difference is a switch to use patchelf, so even if the interpreter section is too small, it can still adjust the binary. Right now this implements a working proof of concept. If you build the tarball and place it at the head of the tree (in COREBASE), you can run a build from sstate and successfully build packages and construct images. There is some improvement needed, its hardcoded for x86_64 right now, its trivial to add 32 bit support too. The tarball isn't fetched right now, there is just a harcoded path assumption and there is no error handling. I haven't figured out the best delivery mechanism for that yet. BuildStarted is probably not the right event to hook on either. I've merged this to illustrate how with a small change, we might make the native/cross sstate much more reusable and hence improve the accessibility of lower overhead builds. With this change, its possible the Yocto Project may be able to support a configured sstate mirror out the box. This also has positive implications for our developer workflow/SDK improvements. (From OE-Core rev: e66c96ae9c7ba21ebd04a4807390f0031238a85a) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/uninative-tarball.bb')
-rw-r--r--meta/recipes-core/meta/uninative-tarball.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/uninative-tarball.bb b/meta/recipes-core/meta/uninative-tarball.bb
new file mode 100644
index 0000000000..ed1279f09b
--- /dev/null
+++ b/meta/recipes-core/meta/uninative-tarball.bb
@@ -0,0 +1,48 @@
1SUMMARY = "libc and patchelf tarball for use with uninative.bbclass"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6TOOLCHAIN_TARGET_TASK = ""
7
8TOOLCHAIN_HOST_TASK = "\
9 nativesdk-eglibc \
10 nativesdk-patchelf \
11 "
12
13INHIBIT_DEFAULT_DEPS = "1"
14DEPENDS += "patchelf-native"
15
16TOOLCHAIN_OUTPUTNAME ?= "${BUILD_ARCH}-nativesdk-libc"
17
18RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
19
20EXCLUDE_FROM_WORLD = "1"
21
22inherit meta
23inherit populate_sdk
24
25deltask install
26deltask package
27
28SDK_PACKAGING_FUNC = ""
29
30fakeroot create_sdk_files() {
31 cp ${COREBASE}/scripts/relocate_sdk.py ${SDK_OUTPUT}/${SDKPATH}/
32
33 # Replace the ##DEFAULT_INSTALL_DIR## with the correct pattern.
34 # Escape special characters like '+' and '.' in the SDKPATH
35 escaped_sdkpath=$(echo ${SDKPATH}/sysroots/${SDK_SYS} |sed -e "s:[\+\.]:\\\\\\\\\0:g")
36 sed -i -e "s:##DEFAULT_INSTALL_DIR##:$escaped_sdkpath:" ${SDK_OUTPUT}/${SDKPATH}/relocate_sdk.py
37}
38
39
40fakeroot tar_sdk() {
41 mkdir -p ${SDK_DEPLOY}
42 cd ${SDK_OUTPUT}/${SDKPATH}
43 mv sysroots/${SDK_SYS} ./${BUILD_SYS}
44 rm sysroots -rf
45 patchelf --set-interpreter ${@''.join('a' for n in xrange(1024))} ./${BUILD_SYS}/usr/bin/patchelf
46 mv ./${BUILD_SYS}/usr/bin/patchelf ./${BUILD_SYS}/usr/bin/patchelf-uninative
47 tar ${SDKTAROPTS} -c --file=${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.tar.bz2 .
48}