summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/signing-keys.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-01-10 14:27:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-06 16:26:52 +0000
commita36d8c437c1e6ba32a14651f8d55092d831dffb8 (patch)
treec48b8dddab3cd81ea7248dfd990bd3bc2cd1273e /meta/recipes-core/meta/signing-keys.bb
parent9d8a46799d46764ed8978d192a1dc2630dd7c4c9 (diff)
downloadpoky-a36d8c437c1e6ba32a14651f8d55092d831dffb8.tar.gz
gnupg: use native version for signing, rather than one provided by host
Using host gpg has been problematic, and particularly this removes the need to serialize package creation, as long as --auto-expand-secmem is passed to gpg-agent, and gnupg >= 2.2.4 is in use (https://dev.gnupg.org/T3530). Sadly, gpg-agent itself is single-threaded, so in the longer run we might want to seek alternatives: https://lwn.net/Articles/742542/ (a smaller issue is that rpm itself runs the gpg fronted in a serial fashion, which slows down the build in cases of recipes with very large amount of packages, e.g. glibc-locale) Note that sstate signing and verification continues to use host gpg, as depending on native gpg would create circular dependencies. [YOCTO #12022] (From OE-Core rev: 08fef6198122fe79d4c1213f9a64b862162ed6cd) (From OE-Core rev: d449179eaf3cc25fdf6757342e9f95562a84696f) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/signing-keys.bb')
-rw-r--r--meta/recipes-core/meta/signing-keys.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/signing-keys.bb b/meta/recipes-core/meta/signing-keys.bb
index 2c1cc3845e..6387d90d47 100644
--- a/meta/recipes-core/meta/signing-keys.bb
+++ b/meta/recipes-core/meta/signing-keys.bb
@@ -41,6 +41,7 @@ python do_get_public_keys () {
41} 41}
42do_get_public_keys[cleandirs] = "${B}" 42do_get_public_keys[cleandirs] = "${B}"
43addtask get_public_keys before do_install 43addtask get_public_keys before do_install
44do_get_public_keys[depends] += "gnupg-native:do_populate_sysroot"
44 45
45do_install () { 46do_install () {
46 if [ -f "${B}/rpm-key" ]; then 47 if [ -f "${B}/rpm-key" ]; then