summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/buildtools-tarball.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-17 17:15:03 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-09 10:43:46 +0100
commitf7fc9737e41f5cd23159b21043b21f354afd8f1b (patch)
tree4a1594cfb95225d8049edc4030939b562879d118 /meta/recipes-core/meta/buildtools-tarball.bb
parentdc1cedcfacb3a0a463dd4299d22fb4b306cfccef (diff)
downloadpoky-f7fc9737e41f5cd23159b21043b21f354afd8f1b.tar.gz
buildtools-tarball: Add an ld.so.conf for nativesdk-binutils
We need to search our own libdirs, then fall back to the system ones as our customised dynamic loader will. Have ld.so.conf reflect that. This ensures that binutils finds libraries here when linking too. (From OE-Core rev: ab729c362684474a8346e5256d636200826feb47) (From OE-Core rev: 8de0aee6befc0541fa40563f63dfe1cc36f064fe) (From OE-Core rev: d7894d3578d9e97185b4a326c346a3fbb6936ab6) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/buildtools-tarball.bb')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index 91df6f1ae9..eca9f1c0e1 100644
--- a/meta/recipes-core/meta/buildtools-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -73,6 +73,10 @@ create_sdk_files_append () {
73 73
74 echo 'export GIT_SSL_CAINFO="${SDKPATHNATIVE}${sysconfdir}/ssl/certs/ca-certificates.crt"' >>$script 74 echo 'export GIT_SSL_CAINFO="${SDKPATHNATIVE}${sysconfdir}/ssl/certs/ca-certificates.crt"' >>$script
75 75
76 mkdir -p ${SDK_OUTPUT}/${SDKPATHNATIVE}${sysconfdir}/
77 echo '${SDKPATHNATIVE}${libdir}
78${SDKPATHNATIVE}${base_libdir}
79include /etc/ld.so.conf' > ${SDK_OUTPUT}/${SDKPATHNATIVE}${sysconfdir}/ld.so.conf
76 if [ "${SDKMACHINE}" = "i686" ]; then 80 if [ "${SDKMACHINE}" = "i686" ]; then
77 echo 'export NO32LIBS="0"' >>$script 81 echo 'export NO32LIBS="0"' >>$script
78 echo 'echo "$BB_ENV_EXTRAWHITE" | grep -q "NO32LIBS"' >>$script 82 echo 'echo "$BB_ENV_EXTRAWHITE" | grep -q "NO32LIBS"' >>$script