summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/buildtools-tarball.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-08-09 14:49:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-12 06:26:15 +0100
commit43af729d3109a370e436d52862ea2e2842dadba6 (patch)
tree6577176281c918d85ed6e17cd48b809a57dae487 /meta/recipes-core/meta/buildtools-tarball.bb
parent635e21fdd56742bd521da5f09467155ffe3cb037 (diff)
downloadpoky-43af729d3109a370e436d52862ea2e2842dadba6.tar.gz
buildtools-tarball: add testsdk task
Add a testsdk task, which is essentially the same as testsdk.bbclass but the test case directory is changed. This lets us exercise the buildtools tarballs at build time. (From OE-Core rev: 39a0e45ced42826832f84cfbf1cf50ed7c334997) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/buildtools-tarball.bb')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index 9775430d4b..6e96cf6c32 100644
--- a/meta/recipes-core/meta/buildtools-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -99,3 +99,16 @@ TOOLCHAIN_NEED_CONFIGSITE_CACHE = ""
99 99
100# The recipe doesn't need any default deps 100# The recipe doesn't need any default deps
101INHIBIT_DEFAULT_DEPS = "1" 101INHIBIT_DEFAULT_DEPS = "1"
102
103python do_testsdk() {
104 import oeqa.sdk.testsdk
105 testsdk = oeqa.sdk.testsdk.TestSDK()
106
107 cases_path = os.path.join(os.path.abspath(os.path.dirname(oeqa.sdk.testsdk.__file__)), "buildtools-cases")
108 testsdk.context_executor_class.default_cases = cases_path
109
110 testsdk.run(d)
111}
112addtask testsdk
113do_testsdk[nostamp] = "1"
114do_testsdk[depends] += "xz-native:do_populate_sysroot"