summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/buildtools-tarball.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-02 23:47:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-04 00:07:29 +0100
commit25c46772a85384144e1fb1ecad3b6956c67c4e07 (patch)
treed7033c9245a5e20fbdedaec10a1bd6b16bfb49d6 /meta/recipes-core/meta/buildtools-tarball.bb
parente1de69667481749d4e1081210a3a216378d034c9 (diff)
downloadpoky-25c46772a85384144e1fb1ecad3b6956c67c4e07.tar.gz
buildtools-tarball/uninative-tarball: Fix for working with populate_sdk under sstate control
Firstly, these recipes are not target (MACHINE) specific so they should by SDK_ARCH based, not PACKAGE_ARCH. Also fix use of SDK_DEPLOY -> SDKDEPOLYDIR after other recent changes. Together these fixes avoid various build failures and ensure the tarballs only get built once rather than multiple times. (From OE-Core rev: 894c9b6ded702897ae4084ef75959cdc8cc6f7a3) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/buildtools-tarball.bb')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index 34df53191b..e84efabd85 100644
--- a/meta/recipes-core/meta/buildtools-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -26,6 +26,9 @@ TOOLCHAIN_HOST_TASK ?= "\
26 nativesdk-locale-base-en-us \ 26 nativesdk-locale-base-en-us \
27 " 27 "
28 28
29MULTIMACH_TARGET_SYS = "${SDK_ARCH}-nativesdk${SDK_VENDOR}-${SDK_OS}"
30PACKAGE_ARCH = "${SDK_ARCH}"
31
29SDK_PACKAGE_ARCHS += "buildtools-dummy-${SDKPKGSUFFIX}" 32SDK_PACKAGE_ARCHS += "buildtools-dummy-${SDKPKGSUFFIX}"
30 33
31TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}" 34TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
@@ -40,6 +43,8 @@ inherit meta
40inherit populate_sdk 43inherit populate_sdk
41inherit toolchain-scripts 44inherit toolchain-scripts
42 45
46do_populate_sdk[stamp-extra-info] = ""
47
43create_sdk_files_append () { 48create_sdk_files_append () {
44 rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config-* 49 rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config-*
45 rm -f ${SDK_OUTPUT}/${SDKPATH}/environment-setup-* 50 rm -f ${SDK_OUTPUT}/${SDKPATH}/environment-setup-*