summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxml/libxml2_2.9.8.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-05-12 16:16:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-12 17:55:11 +0100
commit311f07ebe562933be27847fa6b083ffb50f77919 (patch)
treed0a7e4a6d231901d13f046087a041ce1a3037f72 /meta/recipes-core/libxml/libxml2_2.9.8.bb
parent66d67b818a7bb172f9ab804f9cb5b8e5b9e577f5 (diff)
downloadpoky-311f07ebe562933be27847fa6b083ffb50f77919.tar.gz
libxml2: upgrade 2.9.8 -> 2.9.9
- Drop backported fix-CVE-2017-8872.patch, fix-CVE-2018-14404.patch and 0001-Fix-infinite-loop-in-LZMA-decompression.patch (From OE-Core rev: dc51f92b2a6f2439fa93b9b0c1d8c4c13e884813) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxml/libxml2_2.9.8.bb')
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.8.bb113
1 files changed, 0 insertions, 113 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.8.bb b/meta/recipes-core/libxml/libxml2_2.9.8.bb
deleted file mode 100644
index 62643bc764..0000000000
--- a/meta/recipes-core/libxml/libxml2_2.9.8.bb
+++ /dev/null
@@ -1,113 +0,0 @@
1SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "http://www.xmlsoft.org/"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=96f7296605eae807670fb08947829969 \
9 file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
10 file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
11
12DEPENDS = "zlib virtual/libiconv"
13
14SRC_URI = "http://www.xmlsoft.org/sources/libxml2-${PV}.tar.gz;name=libtar \
15 http://www.w3.org/XML/Test/xmlts20080827.tar.gz;subdir=${BP};name=testtar \
16 file://libxml-64bit.patch \
17 file://runtest.patch \
18 file://run-ptest \
19 file://python-sitepackages-dir.patch \
20 file://libxml-m4-use-pkgconfig.patch \
21 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
22 file://fix-execution-of-ptests.patch \
23 file://fix-CVE-2017-8872.patch \
24 file://fix-CVE-2018-14404.patch \
25 file://0001-Fix-infinite-loop-in-LZMA-decompression.patch \
26 "
27
28SRC_URI[libtar.md5sum] = "b786e353e2aa1b872d70d5d1ca0c740d"
29SRC_URI[libtar.sha256sum] = "0b74e51595654f958148759cfef0993114ddccccbb6f31aee018f3558e8e2732"
30SRC_URI[testtar.md5sum] = "ae3d1ebe000a3972afa104ca7f0e1b4a"
31SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
32
33BINCONFIG = "${bindir}/xml2-config"
34
35PACKAGECONFIG ??= "python \
36 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
37"
38PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
39PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
40
41inherit autotools pkgconfig binconfig-disabled ptest distro_features_check
42
43inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
44
45RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
46
47RDEPENDS_${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
48
49RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-ebcdic-us \
50 glibc-gconv-ibm1141 \
51 glibc-gconv-iso8859-5 \
52 glibc-gconv-euc-jp \
53 locale-base-en-us \
54 "
55
56export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
57
58# WARNING: zlib is required for RPM use
59EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
60EXTRA_OECONF_class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
61EXTRA_OECONF_class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
62EXTRA_OECONF_linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
63
64python populate_packages_prepend () {
65 # autonamer would call this libxml2-2, but we don't want that
66 if d.getVar('DEBIAN_NAMES'):
67 d.setVar('PKG_libxml2', '${MLPREFIX}libxml2')
68}
69
70PACKAGE_BEFORE_PN += "${PN}-utils"
71PACKAGES += "${PN}-python"
72
73FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
74FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
75FILES_${PN}-utils = "${bindir}/*"
76FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
77
78do_configure_prepend () {
79 # executables take longer to package: these should not be executable
80 find ${S}/xmlconf/ -type f -exec chmod -x {} \+
81}
82
83do_compile_ptest() {
84 oe_runmake check-am
85}
86
87do_install_ptest () {
88 cp -r ${S}/xmlconf ${D}${PTEST_PATH}
89 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
90 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
91 ${D}${PTEST_PATH}/python/tests/Makefile
92 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
93 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
94 fi
95 #Remove build host references from various Makefiles
96 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
97 sed -i \
98 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
99 -e 's|${DEBUG_PREFIX_MAP}||g' \
100 -e 's:${HOSTTOOLS_DIR}/::g' \
101 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
102 -e 's:${RECIPE_SYSROOT}::g' \
103 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
104 -e '/^RELDATE/d' \
105 {} +
106}
107
108do_install_append_class-native () {
109 # Docs are not needed in the native case
110 rm ${D}${datadir}/gtk-doc -rf
111}
112
113BBCLASSEXTEND = "native nativesdk"