summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-09-05 17:38:01 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-07 07:47:24 +0100
commit0a16f83d93fd5bf95952a4645c2135b76122e468 (patch)
treed976d0c324685d15e3ae6134d18c2717ae52e05a /meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
parenta18b799d67e54b091b369d4325d73a8abeccef34 (diff)
downloadpoky-0a16f83d93fd5bf95952a4645c2135b76122e468.tar.gz
libxcrypt: update to 4.4.8
LICENSE file checksum changed because few contributors were mentioned (see @edbdbbc50beced9c723e7405334583c60a702796). (From OE-Core rev: 06eb03ad1c0357731496531b290a0a2fdfd10f48) Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
new file mode 100644
index 0000000000..1787f6921e
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Extended cryptographic library (from glibc)"
2DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
3HOMEPAGE = "https://github.com/besser82/libxcrypt"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM ?= "file://LICENSING;md5=3bb6614cf5880cbf1b9dbd9e3d145e2c \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit autotools pkgconfig
11
12SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH}"
13SRCREV = "acd84997a5a8b2badd28b70a642abee11272fad2"
14SRCBRANCH ?= "develop"
15
16PROVIDES = "virtual/crypt"
17
18FILES_${PN} = "${libdir}/libcrypt*.so.* \
19 ${libdir}/libcrypt-*.so \
20 ${libdir}/libowcrypt*.so.* \
21 ${libdir}/libowcrypt-*.so \
22"
23
24S = "${WORKDIR}/git"
25
26BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
27TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error"
28CPPFLAGS_append_class-nativesdk = " -Wno-error"
29
30API = "--disable-obsolete-api"
31EXTRA_OECONF += "${API}"
32
33BBCLASSEXTEND = "nativesdk"