summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/kbd/kbd_2.0.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-05 16:43:43 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-09 12:00:42 +0000
commit7c8a6cbf42271442189e463e9f8772521b4f263d (patch)
tree52710c090fa5a2d5e72804878a07798762121ad3 /meta/recipes-core/kbd/kbd_2.0.4.bb
parent491aac8f8f46bd5501203fef57e33f3ed871555c (diff)
downloadpoky-7c8a6cbf42271442189e463e9f8772521b4f263d.tar.gz
kbd: update to 2.2.0
Rebase set-proper-path-of-resources.patch Add a patch to address a string format error; as it modifies a .l file, add a dependency on flex which is processing that into C source code. License-Update: file with copyright statements was replaced with original GPLv2 text (From OE-Core rev: 729ac34dce472378cec5447c366a28de2081e7de) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/kbd/kbd_2.0.4.bb')
-rw-r--r--meta/recipes-core/kbd/kbd_2.0.4.bb64
1 files changed, 0 insertions, 64 deletions
diff --git a/meta/recipes-core/kbd/kbd_2.0.4.bb b/meta/recipes-core/kbd/kbd_2.0.4.bb
deleted file mode 100644
index 4af3256fff..0000000000
--- a/meta/recipes-core/kbd/kbd_2.0.4.bb
+++ /dev/null
@@ -1,64 +0,0 @@
1SUMMARY = "Keytable files and keyboard utilities"
2HOMEPAGE = "http://www.kbd-project.org/"
3# everything minus console-fonts is GPLv2+
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a5fcc36121d93e1f69d96a313078c8b5"
6
7inherit autotools gettext ptest pkgconfig
8
9RREPLACES_${PN} = "console-tools"
10RPROVIDES_${PN} = "console-tools"
11RCONFLICTS_${PN} = "console-tools"
12
13SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
14 file://run-ptest \
15 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'file://set-proper-path-of-resources.patch', '', d)} \
16 "
17
18SRC_URI[md5sum] = "c1635a5a83b63aca7f97a3eab39ebaa6"
19SRC_URI[sha256sum] = "5fd90af6beb225a9bb9b9fb414c090fba53c9a55793e172f508cd43652e59a88"
20
21PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
22 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests','', d)} \
23 "
24
25PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
26PACKAGECONFIG[tests] = "--enable-tests, --disable-tests, libcheck"
27
28do_compile_ptest() {
29 oe_runmake -C ${B}/tests dumpkeys-fulltable alt-is-meta
30}
31
32do_install_ptest() {
33 install -D ${B}/tests/Makefile ${D}${PTEST_PATH}/tests/Makefile
34 sed -i -e '/Makefile:/,/^$/d' -e '/%: %.in/,/^$/d' \
35 -e 's:--sysroot=${STAGING_DIR_TARGET}::g' \
36 -e 's:${DEBUG_PREFIX_MAP}::g' \
37 -e 's:${HOSTTOOLS_DIR}/::g' \
38 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
39 -e 's:${RECIPE_SYSROOT}::g' \
40 -e 's:${S}/config/missing::g' \
41 -e 's:${WORKDIR}::g' \
42 -e '/libkeymap_.*_SOURCES =/d' -e '/$(EXEEXT):/,/^$/d' ${D}${PTEST_PATH}/tests/Makefile
43
44 find ${B}/tests -executable -exec install {} ${D}${PTEST_PATH}/tests \;
45 find ${S}/tests \( -name \*.map -o -name \*.bin -o -name \*.output \) -exec install {} ${D}${PTEST_PATH}/tests \;
46
47 install -D -m 755 ${S}/config/test-driver ${D}${PTEST_PATH}/config/test-driver
48}
49
50PACKAGES += "${PN}-consolefonts ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
51
52FILES_${PN}-consolefonts = "${datadir}/consolefonts"
53FILES_${PN}-consoletrans = "${datadir}/consoletrans"
54FILES_${PN}-keymaps = "${datadir}/keymaps"
55FILES_${PN}-unimaps = "${datadir}/unimaps"
56
57RDEPENDS_${PN}-ptest = "make"
58
59inherit update-alternatives
60
61ALTERNATIVE_${PN} = "chvt deallocvt fgconsole openvt showkey"
62ALTERNATIVE_PRIORITY = "100"
63
64BBCLASSEXTEND = "native"