summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/initscripts/init-system-helpers_1.60.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-26 10:26:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-30 14:01:06 +0000
commit8ef66328c10e3514935af0099d96fded67e79493 (patch)
tree5fdc9ee3de89f983812ffece838e0ad6522f0724 /meta/recipes-core/initscripts/init-system-helpers_1.60.bb
parent8bb11d7986792a8bd59a744fd15585f1b71aa937 (diff)
downloadpoky-8ef66328c10e3514935af0099d96fded67e79493.tar.gz
init-system-helpers: upgrade 1.58 -> 1.60
(From OE-Core rev: 3ae7b7f72d4b55d66e6f8f8a9bc71e14fb826c47) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/initscripts/init-system-helpers_1.60.bb')
-rw-r--r--meta/recipes-core/initscripts/init-system-helpers_1.60.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-core/initscripts/init-system-helpers_1.60.bb b/meta/recipes-core/initscripts/init-system-helpers_1.60.bb
new file mode 100644
index 0000000000..33977e66c1
--- /dev/null
+++ b/meta/recipes-core/initscripts/init-system-helpers_1.60.bb
@@ -0,0 +1,41 @@
1SUMMARY = "helper tools for all init systems"
2DESCRIPTION = "This package contains helper tools that are necessary for switching between \
3the various init systems that Debian contains (e. g. sysvinit or \
4systemd). An example is deb-systemd-helper, a script that enables systemd unit \
5files without depending on a running systemd. \
6\
7It also includes the \"service\", \"invoke-rc.d\", and \"update-rc.d\" scripts which \
8provide an abstraction for enabling, disabling, starting, and stopping \
9services for all supported Debian init systems as specified by the policy. \
10\
11While this package is maintained by pkg-systemd-maintainers, it is NOT \
12specific to systemd at all. Maintainers of other init systems are welcome to \
13include their helpers in this package."
14HOMEPAGE = "https://salsa.debian.org/debian/init-system-helpers"
15SECTION = "base"
16LICENSE = "BSD-3-Clause & GPLv2"
17LIC_FILES_CHKSUM = "file://debian/copyright;md5=ee2b1830fcfead84d07bc060ec43e072"
18
19SRCREV = "dbd9197569c0935029acd5c9b02b84c68fd937ee"
20SRC_URI = "git://salsa.debian.org/debian/init-system-helpers.git;protocol=https"
21
22S = "${WORKDIR}/git"
23
24do_configure[noexec] = "1"
25do_compile[noexec] = "1"
26
27do_install() {
28 install -d -m 0755 ${D}${sbindir}
29 install -m 0755 ${S}/script/invoke-rc.d ${D}${sbindir}
30 install -m 0755 ${S}/script/service ${D}${sbindir}
31}
32
33PACKAGES += "${PN}-invoke-rc.d ${PN}-service"
34
35FILES_${PN} = ""
36FILES_${PN}-invoke-rc.d = "${sbindir}/invoke-rc.d"
37FILES_${PN}-service = "${sbindir}/service"
38
39ALLOW_EMPTY_${PN} = "1"
40
41RRECOMMENDS_${PN} += "${PN}-invoke-rc.d ${PN}-service"