summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images/core-image-ptest-all.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-05-27 12:54:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-28 06:41:02 +0100
commit121438b52e7889763ca081c4e687722dc74a3def (patch)
tree4a138fdbbe8782cb65f27a26308827d149da0e4e /meta/recipes-core/images/core-image-ptest-all.bb
parent71a4173fc0641c8ec0ed193c9275112f1ac6875d (diff)
downloadpoky-121438b52e7889763ca081c4e687722dc74a3def.tar.gz
images: add ptest images based on core-image-minimal
This greatly reduces build times needed for those images, as they no longer need anything graphical, or -dev packages for everything. (From OE-Core rev: 2db500793d9c39caf7a94050df20684fe703e9f6) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/images/core-image-ptest-all.bb')
-rw-r--r--meta/recipes-core/images/core-image-ptest-all.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-core/images/core-image-ptest-all.bb b/meta/recipes-core/images/core-image-ptest-all.bb
new file mode 100644
index 0000000000..c1d6aa28a9
--- /dev/null
+++ b/meta/recipes-core/images/core-image-ptest-all.bb
@@ -0,0 +1,25 @@
1inherit features_check
2REQUIRED_DISTRO_FEATURES = "ptest"
3
4require core-image-minimal.bb
5require conf/distro/include/ptest-packagelists.inc
6
7DESCRIPTION += "Also includes ptest packages."
8HOMEPAGE = "https://www.yoctoproject.org/"
9
10# Include the full set of ptests
11IMAGE_INSTALL += "${PTESTS_FAST} ${PTESTS_SLOW}"
12
13# This image is sufficiently large (~1.8GB) that we need to be careful that it fits in a live
14# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
15# box) and explicitly add just 1100MB.
16# strace-ptest in particular needs more than 500MB
17IMAGE_OVERHEAD_FACTOR = "1.0"
18IMAGE_ROOTFS_EXTRA_SPACE = "1124288"
19
20# ptests need more memory than standard to avoid the OOM killer
21# also lttng-tools needs /tmp that has at least 1G
22QB_MEM = "-m 2048"
23
24# Sadly at the moment the full set of ptests is not robust enough and sporadically fails in random places
25PTEST_EXPECT_FAILURE = "1"