summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images/build-appliance-image_15.0.0.bb
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2023-02-21 15:44:41 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-23 12:11:29 +0000
commit3f4ce1222d91c50bbce71b9d989af1952e477acd (patch)
treeaebdf793963fa7f873d25438e6806c43827a955d /meta/recipes-core/images/build-appliance-image_15.0.0.bb
parentdd8f5b979668edff08b522bb7e275b5245925dd2 (diff)
downloadpoky-3f4ce1222d91c50bbce71b9d989af1952e477acd.tar.gz
build-appliance-image: add /lib64 symlink
Add a /lib64 -> /lib symlink in case the build appliance is 64-bit. Building rust-native requires cargo to be run. The native cargo is linked to look for /lib64/ld-linux-x86-64.so.2 and can't be run without it. The build produces the following error, even though that file does exist: FileNotFoundError: [Errno 2] No such file or directory: '/home/builder/poky/build/tmp/work/x86_64-linux/rust-native/1.66.1-r0/rust-snapshot/bin/cargo' Trying to run this binary on its own gives: qemux86-64:~/poky/build$ tmp/work/x86_64-linux/rust-native/1.66.1-r0/rust-snapshot/bin/cargo -sh: tmp/work/x86_64-linux/rust-native/1.66.1-r0/rust-snapshot/bin/cargo: cannot execute: required file not found (From OE-Core rev: a62b32907cb059b4512032f15571705540f1c147) Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/images/build-appliance-image_15.0.0.bb')
-rw-r--r--meta/recipes-core/images/build-appliance-image_15.0.0.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index ce5af7764c..6e65922950 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -109,7 +109,13 @@ fakeroot do_populate_poky_src () {
109 chown -R builder:builder ${IMAGE_ROOTFS}/home/builder/.cache 109 chown -R builder:builder ${IMAGE_ROOTFS}/home/builder/.cache
110} 110}
111 111
112IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; " 112fakeroot do_tweak_image () {
113 # add a /lib64 symlink
114 # this is needed for building rust-native on a 64-bit build appliance
115 ln -rs ${IMAGE_ROOTFS}/lib ${IMAGE_ROOTFS}/lib64
116}
117
118IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; do_tweak_image; "
113# For pip usage above 119# For pip usage above
114do_image[network] = "1" 120do_image[network] = "1"
115 121