summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/ldconfig-native_2.12.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-08-28 06:00:54 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-01 18:02:21 +0100
commit54a3375a1084f02ebd95886739e951228e945c57 (patch)
treefe139449256b0ed85504b896a9782bccd8a9d3a1 /meta/recipes-core/glibc/ldconfig-native_2.12.1.bb
parent954e45bc7464573ed4776dbcd72eb76d4fca0b3d (diff)
downloadpoky-54a3375a1084f02ebd95886739e951228e945c57.tar.gz
glibc: Migrate eglibc 2.19 -> glibc 2.20
- This is a big swoop change where we switch to using glibc - option-groups are forward ported - cross-localedef is extracted out from eglibc and hosted at github.com/kraj/localedef, its used for cross-localedef recipe - Other non ported patches from eglibc are forward ported ppc8xx cache line workaround SH fpcr values dynamic resolver installing PIC archives is there but is not applied libc header bootstrap - Delete eglibc recipes we moved back to using glibc now - Fix ppc/e500 build - Fix crypt module build when options are used - Fix fnmatch build when options OPTION_EGLIBC_LOCALE_CODE is unset HAVE_MBSTATE_T and HAVE_MBSRTOWCS should be defined conditionally based upon OPTION_EGLIBC_LOCALE_CODE being set/unset - Move the ports/ patches to relevant files now that ports is gone (From OE-Core rev: 1027c535ea753e63d9ffe469a423e04467cf8940) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/ldconfig-native_2.12.1.bb')
-rw-r--r--meta/recipes-core/glibc/ldconfig-native_2.12.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/ldconfig-native_2.12.1.bb b/meta/recipes-core/glibc/ldconfig-native_2.12.1.bb
new file mode 100644
index 0000000000..7c3463589b
--- /dev/null
+++ b/meta/recipes-core/glibc/ldconfig-native_2.12.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "A standalone native ldconfig build"
2
3LICENSE = "GPLv2+"
4
5LIC_FILES_CHKSUM = "file://${S}/ldconfig.c;endline=17;md5=1d15f20937c055cb5de2329a4c054399"
6
7SRC_URI = "file://ldconfig-native-2.12.1.tar.bz2 \
8 file://ldconfig.patch \
9 file://ldconfig_aux-cache_path_fix.patch \
10 file://32and64bit.patch \
11 file://endian-ness_handling.patch \
12 file://flag_fix.patch \
13 file://endianess-header.patch \
14 file://ldconfig-default-to-all-multilib-dirs.patch \
15"
16
17PR = "r2"
18
19FILESEXTRAPATHS =. "${FILE_DIRNAME}/${P}:"
20
21inherit native
22
23S = "${WORKDIR}/${PN}-${PV}"
24
25do_compile () {
26 $CC ldconfig.c -std=gnu99 chroot_canon.c xmalloc.c xstrdup.c cache.c readlib.c -I. dl-cache.c -o ldconfig
27}
28
29do_install () {
30 install -d ${D}/${bindir}/
31 install ldconfig ${D}/${bindir}/
32}