summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.32.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-04 21:41:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-05 12:00:54 +0000
commit7b8df042d0c175388d6230f008b1c83d5c5cd5da (patch)
treeeffa543d93952e198887369a11b9667d94599349 /meta/recipes-core/glibc/glibc_2.32.bb
parent77d9b5f02aec991540926fe144076e122c17f64d (diff)
downloadpoky-7b8df042d0c175388d6230f008b1c83d5c5cd5da.tar.gz
glibc: Upgrade to 2.33
Drop backported patches (From OE-Core rev: aa87638cf4f2bef66df92f961c7814f6b482fd3d) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.32.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.32.bb118
1 files changed, 0 insertions, 118 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.32.bb b/meta/recipes-core/glibc/glibc_2.32.bb
deleted file mode 100644
index 249f59176e..0000000000
--- a/meta/recipes-core/glibc/glibc_2.32.bb
+++ /dev/null
@@ -1,118 +0,0 @@
1require glibc.inc
2require glibc-version.inc
3
4# whitelist CVE's with fixes in latest release/2.32/master branch
5CVE_CHECK_WHITELIST += "CVE-2019-25013 CVE-2020-10029 CVE-2020-27618"
6
7DEPENDS += "gperf-native bison-native make-native"
8
9NATIVESDKFIXES ?= ""
10NATIVESDKFIXES_class-nativesdk = "\
11 file://0003-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
12 file://0004-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
13 file://0005-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
14 file://0006-nativesdk-glibc-Allow-64-bit-atomics-for-x86.patch \
15 file://0007-nativesdk-glibc-Make-relocatable-install-for-locales.patch \
16"
17
18SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
19 file://etc/ld.so.conf \
20 file://generate-supported.mk \
21 file://makedbs.sh \
22 \
23 ${NATIVESDKFIXES} \
24 file://0008-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
25 file://0009-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
26 file://0010-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
27 file://0011-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
28 file://0012-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
29 file://0013-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
30 file://0014-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
31 file://0015-yes-within-the-path-sets-wrong-config-variables.patch \
32 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
33 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
34 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
35 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
36 file://0020-eglibc-Resolve-__fpscr_values-on-SH4.patch \
37 file://0021-eglibc-Forward-port-cross-locale-generation-support.patch \
38 file://0022-Define-DUMMY_LOCALE_T-if-not-defined.patch \
39 file://0023-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
40 file://0024-elf-dl-deps.c-Make-_dl_build_local_scope-breadth-fir.patch \
41 file://0025-intl-Emit-no-lines-in-bison-generated-files.patch \
42 file://0027-locale-prevent-maybe-uninitialized-errors-with-Os-BZ.patch \
43 file://0028-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
44 file://0029-wordsize.h-Unify-the-header-between-arm-and-aarch64.patch \
45 file://0030-powerpc-Do-not-ask-compiler-for-finding-arch.patch \
46 file://0031-linux-Allow-adjtime-with-NULL-argument-BZ-26833.patch \
47 file://CVE-2020-29562.patch \
48 file://CVE-2020-29573.patch \
49 "
50S = "${WORKDIR}/git"
51B = "${WORKDIR}/build-${TARGET_SYS}"
52
53PACKAGES_DYNAMIC = ""
54
55# the -isystem in bitbake.conf screws up glibc do_stage
56BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
57TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
58
59GLIBC_BROKEN_LOCALES = ""
60
61GLIBCPIE ??= ""
62
63EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
64 --disable-profile \
65 --disable-debug --without-gd \
66 --enable-clocale=gnu \
67 --with-headers=${STAGING_INCDIR} \
68 --without-selinux \
69 --enable-tunables \
70 --enable-bind-now \
71 --enable-stack-protector=strong \
72 --enable-stackguard-randomization \
73 --disable-crypt \
74 --with-default-link \
75 ${@bb.utils.contains_any('SELECTED_OPTIMIZATION', '-O0 -Og', '--disable-werror', '', d)} \
76 ${GLIBCPIE} \
77 ${GLIBC_EXTRA_OECONF}"
78
79EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
80
81PACKAGECONFIG ??= "nscd"
82PACKAGECONFIG[nscd] = "--enable-nscd,--disable-nscd"
83
84do_patch_append() {
85 bb.build.exec_func('do_fix_readlib_c', d)
86}
87
88do_fix_readlib_c () {
89 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
90}
91
92do_configure () {
93# override this function to avoid the autoconf/automake/aclocal/autoheader
94# calls for now
95# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
96# version check and doesn't really help with anything
97 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
98 find ${S} -name "configure" | xargs touch
99 CPPFLAGS="" oe_runconf
100}
101
102LDFLAGS += "-fuse-ld=bfd"
103do_compile () {
104 base_do_compile
105 echo "Adjust ldd script"
106 if [ -n "${RTLDLIST}" ]
107 then
108 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
109 # remove duplicate entries
110 newrtld=`echo $(printf '%s\n' ${prevrtld} ${RTLDLIST} | LC_ALL=C sort -u)`
111 echo "ldd \"${prevrtld} ${RTLDLIST}\" -> \"${newrtld}\""
112 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${newrtld}\"#"
113 fi
114}
115
116require glibc-package.inc
117
118BBCLASSEXTEND = "nativesdk"