summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.25.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-01-12 12:20:50 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-23 12:05:22 +0000
commit49fec741ebd62e6a4157e364321b9fec8931825b (patch)
tree305062cbc3ae0a6ae0bc510bfd05b0c1cb0c3999 /meta/recipes-core/glibc/glibc_2.25.bb
parentf4c96ea8292e9641214c32b5858d7653651b054f (diff)
downloadpoky-49fec741ebd62e6a4157e364321b9fec8931825b.tar.gz
glibc: Upgrade to 2.25 snapshot
glibc 2.25 release is in freeze stage now (From OE-Core rev: b72dbf70646e9dca0dbb5b22bc70d919e6eb8bdc) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.25.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.25.bb142
1 files changed, 142 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.25.bb b/meta/recipes-core/glibc/glibc_2.25.bb
new file mode 100644
index 0000000000..a21fee0a1c
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc_2.25.bb
@@ -0,0 +1,142 @@
1require glibc.inc
2
3LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
4 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
6 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
7
8DEPENDS += "gperf-native"
9
10SRCREV ?= "bb440151433f0298e7a6786ccd30cd084812f897"
11
12#SRCBRANCH ?= "release/${PV}/master"
13SRCBRANCH ?= "master"
14
15GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
16UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.\d+)*)"
17
18SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
19 file://etc/ld.so.conf \
20 file://generate-supported.mk \
21 \
22 ${NATIVESDKFIXES} \
23 file://0005-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
24 file://0006-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
25 file://0007-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
26 file://0008-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
27 file://0009-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
28 file://0010-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
29 file://0011-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
30 file://0012-Make-ld-version-output-matching-grok-gold-s-output.patch \
31 file://0013-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
32 file://0014-Add-unused-attribute.patch \
33 file://0015-yes-within-the-path-sets-wrong-config-variables.patch \
34 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
35 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
36 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
37 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
38 file://0020-eglibc-cherry-picked-from.patch \
39 file://0021-eglibc-Clear-cache-lines-on-ppc8xx.patch \
40 file://0022-eglibc-Resolve-__fpscr_values-on-SH4.patch \
41 file://0023-eglibc-Install-PIC-archives.patch \
42 file://0024-eglibc-Forward-port-cross-locale-generation-support.patch \
43 file://0025-Define-DUMMY_LOCALE_T-if-not-defined.patch \
44 file://0026-elf-dl-deps.c-Make-_dl_build_local_scope-breadth-fir.patch \
45 file://0027-locale-fix-hard-coded-reference-to-gcc-E.patch \
46 file://0028-Revert-Check-IFUNC-definition-in-unrelocated-shared-.patch \
47"
48
49NATIVESDKFIXES ?= ""
50NATIVESDKFIXES_class-nativesdk = "\
51 file://0001-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
52 file://0002-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
53 file://0003-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
54 file://0004-nativesdk-glibc-Allow-64-bit-atomics-for-x86.patch \
55"
56
57S = "${WORKDIR}/git"
58B = "${WORKDIR}/build-${TARGET_SYS}"
59
60PACKAGES_DYNAMIC = ""
61
62# the -isystem in bitbake.conf screws up glibc do_stage
63BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
64TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
65
66GLIBC_BROKEN_LOCALES = ""
67#
68# We will skip parsing glibc when target system C library selection is not glibc
69# this helps in easing out parsing for non-glibc system libraries
70#
71COMPATIBLE_HOST_libc-musl_class-target = "null"
72COMPATIBLE_HOST_libc-uclibc_class-target = "null"
73
74EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
75 --without-cvs --disable-profile \
76 --disable-debug --without-gd \
77 --enable-clocale=gnu \
78 --enable-add-ons \
79 --with-headers=${STAGING_INCDIR} \
80 --without-selinux \
81 --enable-obsolete-rpc \
82 ${GLIBC_EXTRA_OECONF}"
83
84EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
85EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'libc-inet-anl', '--enable-nscd', '--disable-nscd', d)}"
86
87
88do_patch_append() {
89 bb.build.exec_func('do_fix_readlib_c', d)
90}
91
92do_fix_readlib_c () {
93 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
94}
95
96do_configure () {
97# override this function to avoid the autoconf/automake/aclocal/autoheader
98# calls for now
99# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
100# version check and doesn't really help with anything
101 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
102 find ${S} -name "configure" | xargs touch
103 CPPFLAGS="" oe_runconf
104}
105
106rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
107 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
108 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
109
110do_compile () {
111 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
112 unset LDFLAGS
113 base_do_compile
114 (
115 cd ${S}/sunrpc/rpcsvc
116 for r in ${rpcsvc}; do
117 h=`echo $r|sed -e's,\.x$,.h,'`
118 rm -f $h
119 ${B}/sunrpc/cross-rpcgen -h $r -o $h || bbwarn "${PN}: unable to generate header for $r"
120 done
121 )
122 echo "Adjust ldd script"
123 if [ -n "${RTLDLIST}" ]
124 then
125 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
126 if [ "${prevrtld}" != "${RTLDLIST}" ]
127 then
128 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
129 fi
130 fi
131
132}
133
134# Use the host locale archive when built for nativesdk so that we don't need to
135# ship a complete (100MB) locale set.
136do_compile_prepend_class-nativesdk() {
137 echo "complocaledir=/usr/lib/locale" >> ${S}/configparms
138}
139
140require glibc-package.inc
141
142BBCLASSEXTEND = "nativesdk"