summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.21.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-01 23:49:10 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-20 10:26:12 +0000
commita488fd5b61c473065b35e0871d0a277207fff2db (patch)
tree2cc50b127c46b87ff207b6bef615799c1a805b7c /meta/recipes-core/glibc/glibc_2.21.bb
parentdda70ca5525594256904f5663cbbca58e2b33f3e (diff)
downloadpoky-a488fd5b61c473065b35e0871d0a277207fff2db.tar.gz
glibc: Upgrade 2.20 -> 2.21
Drop CVE backports and ppc/fpu detection patch which is not needed anymore Forward port eglibc option groups patch Default to using glibc 2.21 Additional patches needed to appease -Werror option Change-Id: I1873097cec8387ea9e8186a255122938fc28c976 (From OE-Core rev: 6617cc92076764d51f0190786f8d62b8c99ae984) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.21.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb158
1 files changed, 158 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
new file mode 100644
index 0000000000..5ebe2503c1
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -0,0 +1,158 @@
1require glibc.inc
2
3DEPENDS += "gperf-native kconfig-frontends-native"
4
5SRCREV = "edac0a60c7514b8c9b59488cffdac6b22267e757"
6
7#BRANCH = "release/${PV}/master"
8BRANCH = "master"
9
10SRC_URI = "git://sourceware.org/git/glibc.git;branch=${BRANCH} \
11 file://IO-acquire-lock-fix.patch \
12 file://mips-rld-map-check.patch \
13 file://etc/ld.so.conf \
14 file://generate-supported.mk \
15 file://glibc.fix_sqrt2.patch \
16 file://multilib_readlib.patch \
17 file://ppc-sqrt_finite.patch \
18 file://ppc_slow_ieee754_sqrt.patch \
19 file://add_resource_h_to_wait_h.patch \
20 file://0001-R_ARM_TLS_DTPOFF32.patch \
21 file://0001-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
22 file://fix-tibetian-locales.patch \
23 file://ppce6500-32b_slow_ieee754_sqrt.patch \
24 file://grok_gold.patch \
25 file://fix_am_rootsbindir.patch \
26 file://0001-Add-unused-attribute.patch \
27 file://0001-When-disabling-SSE-also-make-sure-that-fpmath-is-not.patch \
28 ${EGLIBCPATCHES} \
29 "
30EGLIBCPATCHES = "\
31 file://timezone-re-written-tzselect-as-posix-sh.patch \
32 file://eglibc.patch \
33 file://option-groups.patch \
34 file://GLRO_dl_debug_mask.patch \
35 file://eglibc-header-bootstrap.patch \
36 file://eglibc-resolv-dynamic.patch \
37 file://eglibc-ppc8xx-cache-line-workaround.patch \
38 file://eglibc-sh4-fpscr_values.patch \
39 file://eglibc-use-option-groups.patch \
40 "
41# file://eglibc-install-pic-archives.patch \
42# file://initgroups_keys.patch \
43#
44
45LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
46 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
47 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
48 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
49
50SRC_URI_append_class-nativesdk = " file://ld-search-order.patch \
51 file://relocatable_sdk.patch \
52 file://relocatable_sdk_fix_openpath.patch \
53 "
54S = "${WORKDIR}/git"
55B = "${WORKDIR}/build-${TARGET_SYS}"
56
57PACKAGES_DYNAMIC = ""
58
59# the -isystem in bitbake.conf screws up glibc do_stage
60BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
61TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
62
63GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
64
65#
66# For now, we will skip building of a gcc package if it is a uclibc one
67# and our build is not a uclibc one, and we skip a glibc one if our build
68# is a uclibc build.
69#
70# See the note in gcc/gcc_3.4.0.oe
71#
72
73python __anonymous () {
74 import re
75 uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None)
76 if uc_os:
77 raise bb.parse.SkipPackage("incompatible with target %s" %
78 d.getVar('TARGET_OS', True))
79}
80
81EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
82 --without-cvs --disable-profile \
83 --disable-debug --without-gd \
84 --enable-clocale=gnu \
85 --enable-add-ons \
86 --with-headers=${STAGING_INCDIR} \
87 --without-selinux \
88 --enable-obsolete-rpc \
89 --with-kconfig=${STAGING_BINDIR_NATIVE} \
90 --disable-nscd \
91 ${GLIBC_EXTRA_OECONF}"
92
93EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
94EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'libc-inet-anl', '--enable-nscd', '--disable-nscd', d)}"
95
96
97do_patch_append() {
98 bb.build.exec_func('do_fix_readlib_c', d)
99}
100
101# for mips glibc now builds syscall tables for all abi's
102# so we make sure that we choose right march option which is
103# compatible with o32,n32 and n64 abi's
104# e.g. -march=mips32 is not compatible with n32 and n64 therefore
105# we filter it out in such case -march=from-abi which will be
106# mips1 when using o32 and mips3 when using n32/n64
107
108TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
109TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
110
111do_fix_readlib_c () {
112 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
113}
114
115do_configure () {
116# override this function to avoid the autoconf/automake/aclocal/autoheader
117# calls for now
118# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
119# version check and doesn't really help with anything
120 if [ -z "`which rpcgen`" ]; then
121 echo "rpcgen not found. Install glibc-devel."
122 exit 1
123 fi
124 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
125 find ${S} -name "configure" | xargs touch
126 CPPFLAGS="" oe_runconf
127}
128
129rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
130 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
131 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
132
133do_compile () {
134 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
135 unset LDFLAGS
136 base_do_compile
137 (
138 cd ${S}/sunrpc/rpcsvc
139 for r in ${rpcsvc}; do
140 h=`echo $r|sed -e's,\.x$,.h,'`
141 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
142 done
143 )
144 echo "Adjust ldd script"
145 if [ -n "${RTLDLIST}" ]
146 then
147 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
148 if [ "${prevrtld}" != "${RTLDLIST}" ]
149 then
150 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
151 fi
152 fi
153
154}
155
156require glibc-package.inc
157
158BBCLASSEXTEND = "nativesdk"