summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.21.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-13 09:08:09 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-28 09:44:07 +0100
commit342958fce10ee49f98094bcce6169a3b521b8301 (patch)
treec6170a78adca1abb4ea0cdaabfc93d08791d0287 /meta/recipes-core/glibc/glibc_2.21.bb
parent744d1ff8cea8408327dcd5b7e0851a1b3d2accd8 (diff)
downloadpoky-342958fce10ee49f98094bcce6169a3b521b8301.tar.gz
glibc: Fix x32 make race
On x32 builds, sysd-syscalls appears malformed since the make-target-directory appears on the wrong line. This causes races during the build process where you can see failures like: Assembler messages: Fatal error: can't create [...]glibc/2.21-r0/build-x86_64-poky-linux-gnux32/time/gettimeofday.os: No such file or directory Assembler messages: Fatal error: can't create [...]glibc/2.21-r0/build-x86_64-poky-linux-gnux32/time/time.os: No such file or directory The issue is that the carriage return is being escaped when it should not be. The change to sysd-syscalls with this change: before: """ $(foreach p,$(sysd-rules-targets),$(objpfx)$(patsubst %,$p,time).os): \ $(..)sysdeps/unix/make-syscalls.sh $(make-target-directory) (echo '#include <dl-vdso.h>'; """ after: """ $(foreach p,$(sysd-rules-targets),$(objpfx)$(patsubst %,$p,time).os): \ $(..)sysdeps/unix/make-syscalls.sh $(make-target-directory) (echo '#include <dl-vdso.h>'; """ which ensures the target directory is correctly created. Only x32 uses the vdso code which contains the bug which is why the error only really appears on x32. (From OE-Core rev: ae4729ed6c5e5443c42f8825dd85873f06a3570e) (From OE-Core rev: c945453a8453dd6dab5aa5a132bea20e73ae4d6d) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.21.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index fcef4ff3e5..2b10f80f51 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -26,6 +26,7 @@ SRC_URI = "git://sourceware.org/git/glibc.git;branch=${BRANCH} \
26 file://0001-When-disabling-SSE-also-make-sure-that-fpmath-is-not.patch \ 26 file://0001-When-disabling-SSE-also-make-sure-that-fpmath-is-not.patch \
27 file://0001-yes-within-the-path-sets-wrong-config-variables.patch \ 27 file://0001-yes-within-the-path-sets-wrong-config-variables.patch \
28 file://elf-Makefile-fix-a-typo.patch \ 28 file://elf-Makefile-fix-a-typo.patch \
29 file://makesyscall.patch \
29 ${EGLIBCPATCHES} \ 30 ${EGLIBCPATCHES} \
30 " 31 "
31EGLIBCPATCHES = "\ 32EGLIBCPATCHES = "\