summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.20.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-01 23:49:10 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-20 10:26:12 +0000
commita488fd5b61c473065b35e0871d0a277207fff2db (patch)
tree2cc50b127c46b87ff207b6bef615799c1a805b7c /meta/recipes-core/glibc/glibc_2.20.bb
parentdda70ca5525594256904f5663cbbca58e2b33f3e (diff)
downloadpoky-a488fd5b61c473065b35e0871d0a277207fff2db.tar.gz
glibc: Upgrade 2.20 -> 2.21
Drop CVE backports and ppc/fpu detection patch which is not needed anymore Forward port eglibc option groups patch Default to using glibc 2.21 Additional patches needed to appease -Werror option Change-Id: I1873097cec8387ea9e8186a255122938fc28c976 (From OE-Core rev: 6617cc92076764d51f0190786f8d62b8c99ae984) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.20.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.20.bb162
1 files changed, 0 insertions, 162 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.20.bb b/meta/recipes-core/glibc/glibc_2.20.bb
deleted file mode 100644
index 8a8b296def..0000000000
--- a/meta/recipes-core/glibc/glibc_2.20.bb
+++ /dev/null
@@ -1,162 +0,0 @@
1require glibc.inc
2
3DEPENDS += "gperf-native kconfig-frontends-native"
4
5PV = "2.20"
6
7SRCREV = "b8079dd0d360648e4e8de48656c5c38972621072"
8
9SRC_URI = "git://sourceware.org/git/glibc.git;branch=release/${PV}/master \
10 file://IO-acquire-lock-fix.patch \
11 file://mips-rld-map-check.patch \
12 file://etc/ld.so.conf \
13 file://generate-supported.mk \
14 file://glibc.fix_sqrt2.patch \
15 file://multilib_readlib.patch \
16 file://ppc-sqrt_finite.patch \
17 file://ppc_slow_ieee754_sqrt.patch \
18 file://add_resource_h_to_wait_h.patch \
19 file://fsl-ppc-no-fsqrt.patch \
20 file://0001-R_ARM_TLS_DTPOFF32.patch \
21 file://0001-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
22 file://fix-tibetian-locales.patch \
23 file://ppce6500-32b_slow_ieee754_sqrt.patch \
24 file://grok_gold.patch \
25 file://fix_am_rootsbindir.patch \
26 ${EGLIBCPATCHES} \
27 ${CVEPATCHES} \
28 "
29EGLIBCPATCHES = "\
30 file://timezone-re-written-tzselect-as-posix-sh.patch \
31 file://eglibc.patch \
32 file://option-groups.patch \
33 file://GLRO_dl_debug_mask.patch \
34 file://eglibc-header-bootstrap.patch \
35 file://eglibc-resolv-dynamic.patch \
36 file://eglibc-ppc8xx-cache-line-workaround.patch \
37 file://eglibc-sh4-fpscr_values.patch \
38 file://eglibc-use-option-groups.patch \
39 "
40# file://eglibc-install-pic-archives.patch \
41# file://initgroups_keys.patch \
42#
43
44CVEPATCHES = "\
45 file://CVE-2014-7817-wordexp-fails-to-honour-WRDE_NOCMD.patch \
46 file://CVE-2012-3406-Stack-overflow-in-vfprintf-BZ-16617.patch \
47 file://CVE-2014-9402_endless-loop-in-getaddr_r.patch \
48 "
49LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
50 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
51 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
52 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
53
54SRC_URI_append_class-nativesdk = " file://ld-search-order.patch \
55 file://relocatable_sdk.patch \
56 file://relocatable_sdk_fix_openpath.patch \
57 "
58S = "${WORKDIR}/git"
59B = "${WORKDIR}/build-${TARGET_SYS}"
60
61PACKAGES_DYNAMIC = ""
62
63# the -isystem in bitbake.conf screws up glibc do_stage
64BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
65TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
66
67GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
68
69#
70# For now, we will skip building of a gcc package if it is a uclibc one
71# and our build is not a uclibc one, and we skip a glibc one if our build
72# is a uclibc build.
73#
74# See the note in gcc/gcc_3.4.0.oe
75#
76
77python __anonymous () {
78 import re
79 uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None)
80 if uc_os:
81 raise bb.parse.SkipPackage("incompatible with target %s" %
82 d.getVar('TARGET_OS', True))
83}
84
85EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
86 --without-cvs --disable-profile \
87 --disable-debug --without-gd \
88 --enable-clocale=gnu \
89 --enable-add-ons \
90 --with-headers=${STAGING_INCDIR} \
91 --without-selinux \
92 --enable-obsolete-rpc \
93 --with-kconfig=${STAGING_BINDIR_NATIVE} \
94 --disable-nscd \
95 ${GLIBC_EXTRA_OECONF}"
96
97EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
98EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'libc-inet-anl', '--enable-nscd', '--disable-nscd', d)}"
99
100
101do_patch_append() {
102 bb.build.exec_func('do_fix_readlib_c', d)
103}
104
105# for mips glibc now builds syscall tables for all abi's
106# so we make sure that we choose right march option which is
107# compatible with o32,n32 and n64 abi's
108# e.g. -march=mips32 is not compatible with n32 and n64 therefore
109# we filter it out in such case -march=from-abi which will be
110# mips1 when using o32 and mips3 when using n32/n64
111
112TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
113TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
114
115do_fix_readlib_c () {
116 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
117}
118
119do_configure () {
120# override this function to avoid the autoconf/automake/aclocal/autoheader
121# calls for now
122# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
123# version check and doesn't really help with anything
124 if [ -z "`which rpcgen`" ]; then
125 echo "rpcgen not found. Install glibc-devel."
126 exit 1
127 fi
128 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
129 find ${S} -name "configure" | xargs touch
130 CPPFLAGS="" oe_runconf
131}
132
133rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
134 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
135 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
136
137do_compile () {
138 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
139 unset LDFLAGS
140 base_do_compile
141 (
142 cd ${S}/sunrpc/rpcsvc
143 for r in ${rpcsvc}; do
144 h=`echo $r|sed -e's,\.x$,.h,'`
145 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
146 done
147 )
148 echo "Adjust ldd script"
149 if [ -n "${RTLDLIST}" ]
150 then
151 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
152 if [ "${prevrtld}" != "${RTLDLIST}" ]
153 then
154 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
155 fi
156 fi
157
158}
159
160require glibc-package.inc
161
162BBCLASSEXTEND = "nativesdk"