summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc-testsuite_2.39.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-02-01 14:24:00 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-06 10:32:19 +0000
commit6d503a7f39831107a6578ba6d5a23291a3d9e913 (patch)
treeb1cb13e63bb2d2d4391a440528c10a7b3985fbf6 /meta/recipes-core/glibc/glibc-testsuite_2.39.bb
parentf4fc8e62321acd7c052a6e85c68a6bc97cfb69e7 (diff)
downloadpoky-6d503a7f39831107a6578ba6d5a23291a3d9e913.tar.gz
glibc: Upgrade to 2.39
License-Update: Relicenses the IBM portions of resolv/base64.c and resolv/res_debug.c to a new license that does not have use-limited patent language [1] Upgrade localdef to get glibc 2.39 build fixes Details of release [2] Add fix for mips clone3 crash [1] https://sourceware.org/git/?p=glibc.git;a=commit;h=ae49a7b29acc184b03c2a6bd6ac01b5e08efd54f [2] https://sourceware.org/glibc/wiki/Release/2.39 (From OE-Core rev: 41ee98ea7e029515a94835952b8563097150f456) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc-testsuite_2.39.bb')
-rw-r--r--meta/recipes-core/glibc/glibc-testsuite_2.39.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc-testsuite_2.39.bb b/meta/recipes-core/glibc/glibc-testsuite_2.39.bb
new file mode 100644
index 0000000000..2e076f4b0f
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc-testsuite_2.39.bb
@@ -0,0 +1,36 @@
1require glibc_${PV}.bb
2require glibc-tests.inc
3
4inherit qemu
5
6SRC_URI += "file://check-test-wrapper"
7
8# strip provides
9PROVIDES = ""
10
11DEPENDS += "${@'qemu-native' if d.getVar('TOOLCHAIN_TEST_TARGET') == 'user' else ''}"
12
13TOOLCHAIN_TEST_TARGET ??= "user"
14TOOLCHAIN_TEST_HOST ??= "localhost"
15TOOLCHAIN_TEST_HOST_USER ??= "root"
16TOOLCHAIN_TEST_HOST_PORT ??= "2222"
17
18do_check[nostamp] = "1"
19do_check[network] = "1"
20do_check:append () {
21 chmod 0755 ${WORKDIR}/check-test-wrapper
22
23 oe_runmake -i \
24 QEMU_SYSROOT="${RECIPE_SYSROOT}" \
25 QEMU_OPTIONS="${@qemu_target_binary(d)} ${QEMU_OPTIONS}" \
26 SSH_HOST="${TOOLCHAIN_TEST_HOST}" \
27 SSH_HOST_USER="${TOOLCHAIN_TEST_HOST_USER}" \
28 SSH_HOST_PORT="${TOOLCHAIN_TEST_HOST_PORT}" \
29 test-wrapper="${WORKDIR}/check-test-wrapper ${TOOLCHAIN_TEST_TARGET}" \
30 check
31}
32
33inherit nopackages
34deltask do_stash_locale
35deltask do_install
36deltask do_populate_sysroot