summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc-testsuite_2.32.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-07 15:09:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-08 09:17:49 +0100
commit392c117e7ab05da10a374f695d5232e7527ab5de (patch)
tree96acdc69cdc0815a3b820101ba14225ae466535d /meta/recipes-core/glibc/glibc-testsuite_2.32.bb
parent470c58ba4586082de802759686460222cc04336d (diff)
downloadpoky-392c117e7ab05da10a374f695d5232e7527ab5de.tar.gz
glibc: Upgrade to 2.32 release
Drop 0001-localedef-Add-hardlink-resolver-to-build.patch as its applied to localedef upstream Drop CVE patches which are already part of 2.32 release Drop unused attribute patch as its fixed differently in 2.32 Add a patch to mitigate the sideffect of [1] for ppc which detect wrong cpu in OE since we are cross compiling [1] https://sourceware.org/git/?p=glibc.git;a=commit;h=146fea07640387c78e334933de24b6353e1f0eba (From OE-Core rev: fe3d5136ef02721f9bbe01d98c1743b8dbcb69c5) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc-testsuite_2.32.bb')
-rw-r--r--meta/recipes-core/glibc/glibc-testsuite_2.32.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc-testsuite_2.32.bb b/meta/recipes-core/glibc/glibc-testsuite_2.32.bb
new file mode 100644
index 0000000000..d887aeff79
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc-testsuite_2.32.bb
@@ -0,0 +1,63 @@
1require glibc_${PV}.bb
2
3EXCLUDE_FROM_WORLD = "1"
4
5# handle PN differences
6FILESEXTRAPATHS_prepend := "${THISDIR}/glibc:"
7
8# strip provides
9PROVIDES = ""
10# setup depends
11INHIBIT_DEFAULT_DEPS = ""
12
13python () {
14 libc = d.getVar("PREFERRED_PROVIDER_virtual/libc")
15 libclocale = d.getVar("PREFERRED_PROVIDER_virtual/libc-locale")
16 if libc != "glibc" or libclocale != "glibc-locale":
17 raise bb.parse.SkipRecipe("glibc-testsuite requires that virtual/libc is glibc")
18}
19
20DEPENDS += "glibc-locale libgcc gcc-runtime"
21
22# remove the initial depends
23DEPENDS_remove = "libgcc-initial"
24
25inherit qemu
26
27SRC_URI += "file://check-test-wrapper"
28
29DEPENDS += "${@'qemu-native' if d.getVar('TOOLCHAIN_TEST_TARGET') == 'user' else ''}"
30
31TOOLCHAIN_TEST_TARGET ??= "user"
32TOOLCHAIN_TEST_HOST ??= "localhost"
33TOOLCHAIN_TEST_HOST_USER ??= "root"
34TOOLCHAIN_TEST_HOST_PORT ??= "2222"
35
36do_check[dirs] += "${B}"
37do_check[nostamp] = "1"
38do_check () {
39 chmod 0755 ${WORKDIR}/check-test-wrapper
40
41 # clean out previous test results
42 oe_runmake tests-clean
43 # makefiles don't clean entirely (and also sometimes fails due to too many args)
44 find ${B} -type f -name "*.out" -delete
45 find ${B} -type f -name "*.test-result" -delete
46 find ${B}/catgets -name "*.cat" -delete
47 find ${B}/conform -name "symlist-*" -delete
48 [ ! -e ${B}/timezone/testdata ] || rm -rf ${B}/timezone/testdata
49
50 oe_runmake -i \
51 QEMU_SYSROOT="${RECIPE_SYSROOT}" \
52 QEMU_OPTIONS="${@qemu_target_binary(d)} ${QEMU_OPTIONS}" \
53 SSH_HOST="${TOOLCHAIN_TEST_HOST}" \
54 SSH_HOST_USER="${TOOLCHAIN_TEST_HOST_USER}" \
55 SSH_HOST_PORT="${TOOLCHAIN_TEST_HOST_PORT}" \
56 test-wrapper="${WORKDIR}/check-test-wrapper ${TOOLCHAIN_TEST_TARGET}" \
57 check
58}
59addtask do_check after do_compile
60
61inherit nopackages
62deltask do_stash_locale
63deltask do_install