summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/cross-localedef-native_2.30.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-04 08:14:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-07 16:08:15 +0100
commit196e56a5d9cadba43bf014bf78f644add2d12e3a (patch)
treee3739ec31f8e9e41de82a1ccecdd559d694358fb /meta/recipes-core/glibc/cross-localedef-native_2.30.bb
parente93572cda749c43cf4ec79870cb4335e03d4ab55 (diff)
downloadpoky-196e56a5d9cadba43bf014bf78f644add2d12e3a.tar.gz
glibc: Update to glibc 2.30
- Drop backported patches - Move common pieces between cross-localedef and glibc into a common file - Move latest checksums to glibc-common.inc and remove duplicates from glibc recipe - Detailed release notes [1] [1] https://sourceware.org/ml/libc-alpha/2019-08/msg00029.html (From OE-Core rev: fe75808dca4bb56ac703d18ebbad4004678f69da) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/cross-localedef-native_2.30.bb')
-rw-r--r--meta/recipes-core/glibc/cross-localedef-native_2.30.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.30.bb b/meta/recipes-core/glibc/cross-localedef-native_2.30.bb
new file mode 100644
index 0000000000..e4923c73d5
--- /dev/null
+++ b/meta/recipes-core/glibc/cross-localedef-native_2.30.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=cfc0ed77a9f62fa62eded042ebe31d72 \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11require glibc-version.inc
12
13# Tell autotools that we're working in the localedef directory
14#
15AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
16
17inherit native
18inherit autotools
19
20FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
21
22SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
23 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \
24 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
25 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
26 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
27 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
28 file://0020-eglibc-Clear-cache-lines-on-ppc8xx.patch \
29 file://0021-eglibc-Resolve-__fpscr_values-on-SH4.patch \
30 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
31 file://0023-Define-DUMMY_LOCALE_T-if-not-defined.patch \
32 file://0024-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
33"
34# Makes for a rather long rev (22 characters), but...
35#
36SRCREV_FORMAT = "glibc_localedef"
37
38S = "${WORKDIR}/git"
39
40EXTRA_OECONF = "--with-glibc=${S}"
41CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
42
43do_install() {
44 install -d ${D}${bindir}
45 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
46}