summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/cross-localedef-native_2.25.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-14 18:23:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-11 15:57:08 +0100
commit1f4f343ff290019987f25d06ea0c00d495660919 (patch)
treef139bbba8e209a1094a0fc14d446a4e0aba9e9be /meta/recipes-core/glibc/cross-localedef-native_2.25.bb
parent715b05e9e193200c2e41fe4881b2ab1fdb639cc2 (diff)
downloadpoky-1f4f343ff290019987f25d06ea0c00d495660919.tar.gz
glibc: Upgrade to 2.25.90
Eventually it will be released as 2.26 final (From OE-Core rev: 5a58883258206893d15990953c8691b05473eecb) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/cross-localedef-native_2.25.bb')
-rw-r--r--meta/recipes-core/glibc/cross-localedef-native_2.25.bb52
1 files changed, 0 insertions, 52 deletions
diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.25.bb b/meta/recipes-core/glibc/cross-localedef-native_2.25.bb
deleted file mode 100644
index cbd16f7263..0000000000
--- a/meta/recipes-core/glibc/cross-localedef-native_2.25.bb
+++ /dev/null
@@ -1,52 +0,0 @@
1SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11# Tell autotools that we're working in the localedef directory
12#
13AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
14
15inherit native
16inherit autotools
17
18FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
19
20SRCBRANCH ?= "release/${PV}/master"
21GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.\d+)*)"
23
24SRCREV_glibc ?= "db0242e3023436757bbc7c488a779e6e3343db04"
25SRCREV_localedef ?= "29869b6dc11427c5bab839bdb155c85a7c644c71"
26
27SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
28 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \
29 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
30 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
31 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
32 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
33 file://0020-eglibc-cherry-picked-from.patch \
34 file://0021-eglibc-Clear-cache-lines-on-ppc8xx.patch \
35 file://0022-eglibc-Resolve-__fpscr_values-on-SH4.patch \
36 file://0023-eglibc-Install-PIC-archives.patch \
37 file://0024-eglibc-Forward-port-cross-locale-generation-support.patch \
38 file://0025-Define-DUMMY_LOCALE_T-if-not-defined.patch \
39"
40# Makes for a rather long rev (22 characters), but...
41#
42SRCREV_FORMAT = "glibc_localedef"
43
44S = "${WORKDIR}/git"
45
46EXTRA_OECONF = "--with-glibc=${S}"
47CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
48
49do_install() {
50 install -d ${D}${bindir}
51 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
52}