summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/cross-localedef-native_2.21.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-01 23:49:10 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-20 10:26:12 +0000
commita488fd5b61c473065b35e0871d0a277207fff2db (patch)
tree2cc50b127c46b87ff207b6bef615799c1a805b7c /meta/recipes-core/glibc/cross-localedef-native_2.21.bb
parentdda70ca5525594256904f5663cbbca58e2b33f3e (diff)
downloadpoky-a488fd5b61c473065b35e0871d0a277207fff2db.tar.gz
glibc: Upgrade 2.20 -> 2.21
Drop CVE backports and ppc/fpu detection patch which is not needed anymore Forward port eglibc option groups patch Default to using glibc 2.21 Additional patches needed to appease -Werror option Change-Id: I1873097cec8387ea9e8186a255122938fc28c976 (From OE-Core rev: 6617cc92076764d51f0190786f8d62b8c99ae984) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/cross-localedef-native_2.21.bb')
-rw-r--r--meta/recipes-core/glibc/cross-localedef-native_2.21.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.21.bb b/meta/recipes-core/glibc/cross-localedef-native_2.21.bb
new file mode 100644
index 0000000000..814ae9df92
--- /dev/null
+++ b/meta/recipes-core/glibc/cross-localedef-native_2.21.bb
@@ -0,0 +1,57 @@
1SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11
12inherit native
13inherit autotools
14
15FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
16
17#BRANCH = "release/${PV}/master"
18BRANCH = "master"
19
20SRC_URI = "git://sourceware.org/git/glibc.git;branch=${BRANCH};name=glibc \
21 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \
22 file://fix_for_centos_5.8.patch \
23 ${EGLIBCPATCHES} \
24 "
25EGLIBCPATCHES = "\
26 file://timezone-re-written-tzselect-as-posix-sh.patch \
27 file://eglibc.patch \
28 file://option-groups.patch \
29 file://GLRO_dl_debug_mask.patch \
30 file://eglibc-header-bootstrap.patch \
31 file://eglibc-resolv-dynamic.patch \
32 file://eglibc-ppc8xx-cache-line-workaround.patch \
33 file://eglibc-sh4-fpscr_values.patch \
34 file://eglibc-use-option-groups.patch \
35 "
36
37SRCREV_glibc = "edac0a60c7514b8c9b59488cffdac6b22267e757"
38SRCREV_localedef = "c833367348d39dad7ba018990bfdaffaec8e9ed3"
39
40# Makes for a rather long rev (22 characters), but...
41#
42SRCREV_FORMAT = "glibc_localedef"
43
44S = "${WORKDIR}/git"
45
46EXTRA_OECONF = "--with-glibc=${S}"
47CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
48
49do_configure () {
50 ${S}/localedef/configure ${EXTRA_OECONF}
51}
52
53
54do_install() {
55 install -d ${D}${bindir}
56 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
57}