summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/cross-localedef-native_2.20.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-01 23:49:10 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-20 10:26:12 +0000
commita488fd5b61c473065b35e0871d0a277207fff2db (patch)
tree2cc50b127c46b87ff207b6bef615799c1a805b7c /meta/recipes-core/glibc/cross-localedef-native_2.20.bb
parentdda70ca5525594256904f5663cbbca58e2b33f3e (diff)
downloadpoky-a488fd5b61c473065b35e0871d0a277207fff2db.tar.gz
glibc: Upgrade 2.20 -> 2.21
Drop CVE backports and ppc/fpu detection patch which is not needed anymore Forward port eglibc option groups patch Default to using glibc 2.21 Additional patches needed to appease -Werror option Change-Id: I1873097cec8387ea9e8186a255122938fc28c976 (From OE-Core rev: 6617cc92076764d51f0190786f8d62b8c99ae984) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/cross-localedef-native_2.20.bb')
-rw-r--r--meta/recipes-core/glibc/cross-localedef-native_2.20.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.20.bb b/meta/recipes-core/glibc/cross-localedef-native_2.20.bb
deleted file mode 100644
index 8aaa225706..0000000000
--- a/meta/recipes-core/glibc/cross-localedef-native_2.20.bb
+++ /dev/null
@@ -1,56 +0,0 @@
1SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11
12inherit native
13inherit autotools
14
15FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
16
17PV = "2.20"
18
19SRC_URI = "git://sourceware.org/git/glibc.git;branch=release/${PV}/master;name=glibc \
20 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \
21 file://fix_for_centos_5.8.patch \
22 ${EGLIBCPATCHES} \
23 "
24EGLIBCPATCHES = "\
25 file://timezone-re-written-tzselect-as-posix-sh.patch \
26 file://eglibc.patch \
27 file://option-groups.patch \
28 file://GLRO_dl_debug_mask.patch \
29 file://eglibc-header-bootstrap.patch \
30 file://eglibc-resolv-dynamic.patch \
31 file://eglibc-ppc8xx-cache-line-workaround.patch \
32 file://eglibc-sh4-fpscr_values.patch \
33 file://eglibc-use-option-groups.patch \
34 "
35
36SRCREV_glibc = "b8079dd0d360648e4e8de48656c5c38972621072"
37SRCREV_localedef = "c833367348d39dad7ba018990bfdaffaec8e9ed3"
38
39# Makes for a rather long rev (22 characters), but...
40#
41SRCREV_FORMAT = "glibc__localedef"
42
43S = "${WORKDIR}/git"
44
45EXTRA_OECONF = "--with-glibc=${S}"
46CFLAGS += "-DNOT_IN_libc=1"
47
48do_configure () {
49 ${S}/localedef/configure ${EXTRA_OECONF}
50}
51
52
53do_install() {
54 install -d ${D}${bindir}
55 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
56}