summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.72.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-08-19 09:27:00 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-08-21 22:51:42 +0100
commit47e0b3f80d4b3e5acf0d44253ba50c5ebed6af85 (patch)
tree096784e9b3f34e495a06731068cc8e317b467027 /meta/recipes-core/glib-networking/glib-networking_2.72.2.bb
parent23afabfa5f8f1534aeb793fb3562f93ca95fdd14 (diff)
downloadpoky-47e0b3f80d4b3e5acf0d44253ba50c5ebed6af85.tar.gz
glib-networking: upgrade 2.72.1 -> 2.72.2
(From OE-Core rev: 10d01291e67d7308e1758590ac020af24ed0a42f) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.72.2.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.72.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.72.2.bb b/meta/recipes-core/glib-networking/glib-networking_2.72.2.bb
new file mode 100644
index 0000000000..746d1bc39c
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.72.2.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPL-2.1-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0"
11
12SRC_URI[archive.sha256sum] = "cd2a084c7bb91d78e849fb55d40e472f6d8f6862cddc9f12c39149359ba18268"
13
14PACKAGECONFIG ??= "openssl ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
15
16PACKAGECONFIG[gnutls] = "-Dgnutls=enabled,-Dgnutls=disabled,gnutls"
17PACKAGECONFIG[openssl] = "-Dopenssl=enabled,-Dopenssl=disabled,openssl"
18PACKAGECONFIG[libproxy] = "-Dlibproxy=enabled,-Dlibproxy=disabled,libproxy"
19PACKAGECONFIG[tests] = "-Dinstalled_tests=true,-Dinstalled_tests=false"
20
21EXTRA_OEMESON = "-Dgnome_proxy=disabled"
22
23GNOMEBASEBUILDCLASS = "meson"
24inherit gnomebase gettext upstream-version-is-even gio-module-cache ptest-gnome
25
26SRC_URI += "file://run-ptest"
27
28FILES:${PN} += "\
29 ${libdir}/gio/modules/libgio*.so \
30 ${datadir}/dbus-1/services/ \
31 ${systemd_user_unitdir} \
32 "
33FILES:${PN}-dev += "${libdir}/gio/modules/libgio*.la"
34FILES:${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"
35
36RDEPENDS:${PN}-ptest += "bash"
37
38BBCLASSEXTEND = "native nativesdk"