summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-10-08 17:17:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-14 16:55:32 +0100
commit3d15fdcd2d1900d18b1e6a23619e8c072390e33d (patch)
tree2be19303f7fb9a93d9afb77addff3a43280f4f29 /meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
parentb740c9275e33ee53b9a530aa7321ddacef58dba5 (diff)
downloadpoky-3d15fdcd2d1900d18b1e6a23619e8c072390e33d.tar.gz
glib-networking: upgrade to 2.38.0 and PACKAGECONFIGise
Use PACKAGECONFIG to add options for ca-certificates, gnutls, and libproxy. Enable ca-certificates by default as all it needs to know is the right path, ca-certificates not being installed isn't fatal. (From OE-Core rev: 1f03b6aa9e475f341815788613513ff63add8a5f) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.38.0.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.38.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb b/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
new file mode 100644
index 0000000000..ad9ad64f8a
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
2HOMEPAGE = "http://git.gnome.org/browse/glib-networking/"
3BUGTRACKER = "http://bugzilla.gnome.org"
4
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8SECTION = "libs"
9DEPENDS = "glib-2.0 intltool-native"
10
11GNOME_COMPRESS_TYPE = "xz"
12
13SRC_URI[archive.md5sum] = "a22907deed3d956860d83aa3233e86ff"
14SRC_URI[archive.sha256sum] = "a43eacbf721b475cf6ba0cd2eab02a332014f71a4c41d0b44bd7bbf8ed1f840d"
15
16PACKAGECONFIG ??= "ca-certificates gnutls"
17
18# No explicit dependency as it works without ca-certificates installed
19PACKAGECONFIG[ca-certificates] = "--with-ca-certificates=${sysconfdir}/ssl/certs/ca-certificates.crt,--without-ca-certificates"
20PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
21PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
22PACKAGECONFIG[pkcs11] = "--with-pkcs11,--without-pkcs11,p11-kit"
23
24EXTRA_OECONF = "--without-gnome-proxy"
25
26inherit gnomebase
27
28FILES_${PN} += "${libdir}/gio/modules/libgio*.so ${datadir}/dbus-1/services/"
29FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/"
30FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
31FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"