summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0/glib-2.0_2.34.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-11-05 16:22:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-12 13:36:38 +0000
commit35d5e2f67aef361c2ab20ab764142d9f98eed855 (patch)
tree82f4d9c42c91a127bf263e61a1f9c375d8c0c2bb /meta/recipes-core/glib-2.0/glib-2.0_2.34.1.bb
parent970aa6dd064b992ad677fd9271d733b3be414af8 (diff)
downloadpoky-35d5e2f67aef361c2ab20ab764142d9f98eed855.tar.gz
glib-2.0: upgrade to latest stable, 2.34.1.
Also explicitly disable the test suite (as we can't run it), subsequently dropping 60_wait-longer-for-threads-to-die.patch and nodbus.patch. nolibelf.patch has been merged upstream, drop. Upstream has dropped the pre-generated man pages, to generate them again we'd need libxslt and the DocBook infrastructure. We can live without the man pages as those build-dependencies are non-trivial. (From OE-Core rev: ce5fcad59fff19dbffc2d7b49c0c8bf3701d17ed) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-2.0/glib-2.0_2.34.1.bb')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.34.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.34.1.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.34.1.bb
new file mode 100644
index 0000000000..18a155de8c
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.34.1.bb
@@ -0,0 +1,39 @@
1require glib.inc
2
3PR = "r0"
4PE = "1"
5
6DEPENDS += "libffi python-argparse-native zlib"
7DEPENDS_class-native += "libffi-native python-argparse-native"
8DEPENDS_class-nativesdk += "nativesdk-libffi python-argparse-native nativesdk-zlib ${BPN}-native"
9
10SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
13 file://configure-libtool.patch \
14 file://glib-2.0_fix_for_x32.patch \
15 "
16SRC_URI[md5sum] = "ee779493b083be9348a841e0a51f1b27"
17SRC_URI[sha256sum] = "6e84dc9d84b104725b34d255421ed7ac3629e49f437d37addde5ce3891c2e2f1"
18
19SRC_URI_append_class-native = " file://glib-gettextize-dir.patch"
20BBCLASSEXTEND = "native nativesdk"
21
22do_configure_prepend() {
23 sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/gio/gdbus-2.0/codegen/gdbus-codegen.in
24}
25
26do_install_append() {
27 # remove some unpackaged files
28 rm -f ${D}${libdir}/gdbus-2.0/codegen/*.pyc
29 rm -f ${D}${libdir}/gdbus-2.0/codegen/*.pyo
30 # and empty dirs
31 rmdir ${D}${libdir}/gio/modules/
32 rmdir ${D}${libdir}/gio/
33
34 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
35 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
36 if [ -f ${D}${bindir}/glib-mkenums ]; then
37 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/glib-mkenums
38 fi
39}