summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.20.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-17 17:00:09 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-02 16:39:13 +0000
commit4cd9a3045c87b37a2d48142bd78ab1e2616026f8 (patch)
treeca2f82e49d5a32ce6c339ed34e5b6154dbcf32be /meta/recipes-core/gettext/gettext_0.20.1.bb
parent0ae95bcc5113a9913aeabaccd5629f2165d986ed (diff)
downloadpoky-4cd9a3045c87b37a2d48142bd78ab1e2616026f8.tar.gz
gettext: update to 0.20.1
License-Update: URLs changed from http to https (From OE-Core rev: c9f8b48ddae0c951fe4df99fda062526160c0a9f) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.20.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.20.1.bb187
1 files changed, 187 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.20.1.bb b/meta/recipes-core/gettext/gettext_0.20.1.bb
new file mode 100644
index 0000000000..fc05ef2e0a
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.20.1.bb
@@ -0,0 +1,187 @@
1SUMMARY = "Utilities and libraries for producing multi-lingual messages"
2DESCRIPTION = "GNU gettext is a set of tools that provides a framework to help other programs produce multi-lingual messages. \
3These tools include a set of conventions about how programs should be written to support message catalogs, a directory and file \
4naming organization for the message catalogs themselves, a runtime library supporting the retrieval of translated messages, and \
5a few stand-alone programs to massage in various ways the sets of translatable and already translated strings."
6HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
7SECTION = "libs"
8LICENSE = "GPLv3+ & LGPL-2.1+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
10
11# Because po-gram-gen.y has been modified by fix-CVE-2018-18751.patch,
12# it requires yacc which provided by bison-native
13# Please remove bison-native from DEPENDS* when next upgrade
14DEPENDS = "bison-native gettext-native virtual/libiconv"
15DEPENDS_class-native = "bison-native gettext-minimal-native"
16PROVIDES = "virtual/libintl virtual/gettext"
17PROVIDES_class-native = "virtual/gettext-native"
18RCONFLICTS_${PN} = "proxy-libintl"
19SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
20 file://parallel.patch \
21 file://add-with-bisonlocaledir.patch \
22 file://cr-statement.c-timsort.h-fix-formatting-issues.patch \
23 file://use-pkgconfig.patch \
24 file://run-ptest \
25 file://serial-tests-config.patch \
26 "
27
28SRC_URI[md5sum] = "bb5b0c0caa028105f3ca1905ddc306e2"
29SRC_URI[sha256sum] = "66415634c6e8c3fa8b71362879ec7575e27da43da562c798a8a2f223e6e47f5c"
30
31inherit autotools texinfo pkgconfig ptest
32
33EXTRA_OECONF += "--without-lispdir \
34 --disable-csharp \
35 --disable-libasprintf \
36 --disable-java \
37 --disable-native-java \
38 --disable-openmp \
39 --disable-acl \
40 --without-emacs \
41 --without-cvs \
42 --without-git \
43 --cache-file=${B}/config.cache \
44 "
45EXTRA_OECONF_append_class-target = " \
46 --with-bisonlocaledir=${datadir}/locale \
47"
48
49PACKAGECONFIG ??= "croco glib libxml"
50PACKAGECONFIG_class-native = ""
51PACKAGECONFIG_class-nativesdk = ""
52
53PACKAGECONFIG[croco] = "--without-included-libcroco,--with-included-libcroco,libcroco"
54PACKAGECONFIG[glib] = "--without-included-glib,--with-included-glib,glib-2.0"
55PACKAGECONFIG[libxml] = "--without-included-libxml,--with-included-libxml,libxml2"
56# Need paths here to avoid host contamination but this can cause RPATH warnings
57# or problems if $libdir isn't $prefix/lib.
58PACKAGECONFIG[libunistring] = "--with-libunistring-prefix=${STAGING_LIBDIR}/..,--with-included-libunistring,libunistring"
59PACKAGECONFIG[msgcat-curses] = "--with-libncurses-prefix=${STAGING_LIBDIR}/..,--disable-curses,ncurses,"
60
61acpaths = '-I ${S}/gettext-runtime/m4 \
62 -I ${S}/gettext-tools/m4'
63
64do_install_append_libc-musl () {
65 rm -f ${D}${libdir}/charset.alias
66 rm -f ${D}${includedir}/libintl.h
67 rm -f ${D}${libdir}/libintl.la
68}
69
70# these lack the .x behind the .so, but shouldn't be in the -dev package
71# Otherwise you get the following results:
72# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
73# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
74# because gettext depends on gettext-dev, which pulls in more -dev packages:
75# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
76# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
77# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
78# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
79
80PACKAGES =+ "libgettextlib libgettextsrc"
81FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
82FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
83
84PACKAGES =+ "gettext-runtime gettext-runtime-dev gettext-runtime-doc"
85
86FILES_${PN} += "${libdir}/${BPN}/*"
87
88# The its/Makefile.am has defined:
89# itsdir = $(pkgdatadir)$(PACKAGE_SUFFIX)/its
90# not itsdir = $(pkgdatadir), so use wildcard to match the version.
91FILES_${PN} += "${datadir}/${BPN}-*/*"
92
93FILES_gettext-runtime = "${bindir}/gettext \
94 ${bindir}/ngettext \
95 ${bindir}/envsubst \
96 ${bindir}/gettext.sh \
97 ${libdir}/libasprintf.so* \
98 ${libdir}/GNU.Gettext.dll \
99 "
100FILES_gettext-runtime-dev += "${libdir}/libasprintf.a \
101 ${includedir}/autosprintf.h \
102 "
103FILES_gettext-runtime-doc = "${mandir}/man1/gettext.* \
104 ${mandir}/man1/ngettext.* \
105 ${mandir}/man1/envsubst.* \
106 ${mandir}/man1/.* \
107 ${mandir}/man3/* \
108 ${docdir}/gettext/gettext.* \
109 ${docdir}/gettext/ngettext.* \
110 ${docdir}/gettext/envsubst.* \
111 ${docdir}/gettext/*.3.html \
112 ${datadir}/gettext/ABOUT-NLS \
113 ${docdir}/gettext/csharpdoc/* \
114 ${docdir}/libasprintf/autosprintf.html \
115 ${infodir}/autosprintf.info \
116 "
117
118do_install_append() {
119 rm -f ${D}${libdir}/preloadable_libintl.so
120}
121
122do_install_append_class-native () {
123 rm ${D}${datadir}/aclocal/*
124 rm ${D}${datadir}/gettext/config.rpath
125 rm ${D}${datadir}/gettext/po/Makefile.in.in
126 rm ${D}${datadir}/gettext/po/remove-potcdate.sin
127
128 create_wrapper ${D}${bindir}/msgfmt \
129 GETTEXTDATADIR="${STAGING_DATADIR_NATIVE}/gettext-0.20/"
130
131}
132
133do_compile_ptest() {
134 cd ${B}/gettext-tools/tests/
135 sed -i '/^buildtest-TESTS: /c buildtest-TESTS: $(TESTS) $(check_PROGRAMS)' Makefile
136 oe_runmake buildtest-TESTS
137 cd -
138}
139
140do_install_ptest() {
141 if [ ${PTEST_ENABLED} = "1" ]; then
142 mkdir -p ${D}${PTEST_PATH}/tests
143 mkdir -p ${D}${PTEST_PATH}/src
144 mkdir -p ${D}${PTEST_PATH}/po
145 mkdir -p ${D}${PTEST_PATH}/misc
146 cp -rf ${S}/gettext-tools/tests/* ${D}${PTEST_PATH}/tests
147 cp -rf ${B}/gettext-tools/tests/.libs/* ${D}${PTEST_PATH}/tests
148 cp -rf ${B}/gettext-runtime/intl/.libs/libgnuintl.so.8* ${D}${libdir}/
149 cp -rf ${B}/gettext-tools/tests/Makefile ${D}${PTEST_PATH}/tests
150 sed -i '/^Makefile:/c Makefile:' ${D}${PTEST_PATH}/tests/Makefile
151 sed -i -e 's:CONFIG_SHELL=.*:& LOCALE_FR='fr_FR.iso88591' LOCALE_FR_UTF8='fr_FR.utf8' LOCALE_JA='ja_JP.eucjp':g' \
152 -e 's:lang-c lang-c++:lang-c++:g' ${D}${PTEST_PATH}/tests/Makefile
153 install ${S}/gettext-tools/src/msgunfmt.tcl ${D}${PTEST_PATH}/src
154 install ${S}/gettext-tools/src/project-id ${D}${PTEST_PATH}/src
155 install ${B}/gettext-runtime/src/gettext.sh ${D}${PTEST_PATH}/src
156 install ${B}/gettext-runtime/src/ngettext ${D}${PTEST_PATH}/src
157 install ${B}/gettext-runtime/src/envsubst ${D}${PTEST_PATH}/src
158 install ${B}/gettext-runtime/src/gettext ${D}${PTEST_PATH}/src
159 install ${B}/gettext-tools/src/.libs/cldr-plurals ${D}${PTEST_PATH}/src
160 install ${S}/gettext-tools/po/gettext-tools.pot ${D}${PTEST_PATH}/po
161 install ${B}/gettext-tools/misc/* ${D}${PTEST_PATH}/misc
162 find ${D}${PTEST_PATH}/ -name "*.o" -exec rm {} \;
163 chmod 0755 ${D}${PTEST_PATH}/tests/lang-vala ${D}${PTEST_PATH}/tests/plural-1 ${D}${PTEST_PATH}/tests/xgettext-tcl-4 \
164 ${D}${PTEST_PATH}/tests/xgettext-vala-1 ${D}${PTEST_PATH}/tests/xgettext-po-2
165 fi
166}
167
168RDEPENDS_${PN}-ptest += "make"
169RDEPENDS_${PN}-ptest_append_libc-glibc = "\
170 glibc-gconv-big5 \
171 glibc-charmap-big5 \
172 glibc-gconv-cp1251 \
173 glibc-charmap-cp1251 \
174 glibc-charmap-iso-8859-9 \
175 glibc-gconv-iso8859-9 \
176 glibc-charmap-koi8-r \
177 glibc-gconv-koi8-r \
178 glibc-gconv-iso8859-2 \
179 glibc-charmap-iso-8859-2 \
180 glibc-gconv-euc-kr \
181 glibc-charmap-euc-kr \
182"
183
184INSANE_SKIP_${PN}-ptest += "ldflags"
185INSANE_SKIP_${PN}-ptest += "rpaths"
186
187BBCLASSEXTEND = "native nativesdk"